unable to restore using GUI

Giggles220Giggles220 Posts: 154
edited September 1, 2008 1:40PM in SQL Backup Previous Versions
After a fatal data error overnight I tried to restore from my 6:30am Transaction Log file this morning. When I right clicked on it and selected restore it came back with an error: Selected backup cannot be restored. SQL Backup has detected that more recent backups have used the same backup file name. My backups are saved in the format of dbname_Date_HHMMSS. No backup has the same name. when I click the restore the button and try and select the files they aren't even listed. I finally was able to restore by adding the files and going through but I don't understand why SQL Backup is saying that files have the same name.

Comments

  • Hi,

    This behaviour sounds extremely strange and I haven't encountered it before.

    Was it just the one file that came up with this error or is it a regular occurrence?

    Thanks
    Matthew Flatt
    Redgate Foundry
  • I had this happen for several files. Now I can't seem to reproduce it at all now.
  • I have had this happen yesterday for all the full database backups on one of our servers. The odd thing is this only affects a remote GUI. It does not affect the GUI if I run it locally on the server however?

    Error
    'SQL Backup has detected that more recent backups have used the same backup file name(s)'

    All our backups use the <AUTO> tag so include the date and time so the files do not have the same name?

    I have some screenshots of the error and lack there of if you are interested.
  • I have managed to resolve this using the same workaround as the issue with verify (stickied in the forum). But for completeness

    I deleted the local data cache located in the folder
    C:\Documents and Settings\<user name>\Local Settings\Application Data\Red Gate\SQL Backup\Server Data. This will cause the user interface to fetch the backup history data in order to create a new local cache which could have a temporary performance impact on the GUI.
  • Andrew,

    If you could e-mail your screenshots etc to [email protected] quoting reference F0014822 that would be useful.

    Thanks!
    Matthew Flatt
    Redgate Foundry
  • Giggles220,

    Have you deleted the client side cache in C:\Documents and Settings\<user name>\Local Settings\Application Data\Red Gate\SQL Backup\Server Data or is it still on your system?

    If you have not deleted it would you be able to send it to [email protected] quoting the reference above?

    Andrew,

    If you run into this again could you also do the same?

    Thanks guys!
    Matthew Flatt
    Redgate Foundry
Sign In or Register to comment.