could not analyze method

I am having an issue with Exception hunter.

I downloaded the 14 day trial and stated using it. I loaded an assembly and found some unhandled exceptions and then unloaded all assemblies. Then I loaded another assembly and every method I tried gave the following error message:

could not analyze method: [Method name]
non-negative number required.
Parameter name: count

I then tried the previous assembly again and got the message on methods that had previously worked. I have tried restarting the app and still cannot get it to analyze any methods. In the course of the checking the first assembly I had turned on and off the following options:

Ignore code branches
Use more detailed analysis

I had also cleared the analysis messages once.

Any thought on how to fix this issue?

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hello,

    I think that this could be solved by clearing out Exception Hunter's cache. This can be found at %userprofile%Local Settings\Application Data\Red Gate\Exception Hunter 1.

    If this doesn't help, please let us know.
  • I get the same error too with a different exception of "Object reference not set to an instance of an object".

    Could someone please help me abot the issue?
Sign In or Register to comment.