What are the challenges you face when working across database platforms? Take the survey
Options

Bug? Insert table column in Regex column

dlutzdlutz Posts: 10
I have a Regex column that is using the value of another column by using the "Insert Table Column" button. The results look great in the preview view but only garbage ends up in the database.
For example, a value in the inserted column of "620 North Milton Blvd." gives the Regex column a value of:
"CL9DBKHJ9NGPYSUOV2X0L3YCFNF899289DL2PUL54A9WQS6K6ELR1QW8NXYO4990L8FL6SY0GRVBU1MNHV1VOB6IHCESWX1U09BICKDDFKA9VKELBB788EC91W4TE64JQ1BKQ3AWING30WNWYSGLQSMMW1GFGJZ8GRJU9TV70AQKY88498VMPITYEOOPNVGYO7N9DTM4X9LF12NOSB67OCJXYKFK55J4TSVRKZRFLQPGXDWB1ZXBP89CNQBTD1YRPGL97W3TKQMXN3ZKN3J588FLII3UNY1JRYQHRN44W3RYMCOKRR5AITIH00QOT96MP25PCHTZZF94GHY6UI2WSR1YF8HQWGAMX59J6Z89X5A3JD1I2KUB69TX1694022J4N6A8FZVATYMGYF27YOCMZGNBBH0P39U2RYW6Q9MLZ1DB6H3R7X1EQX56IYXXZ56J3JOZJVGO1QMX2C5UD8I68GCUSPNRCOLTVT7NS38BGCCZA846T3JQNZBN7U6T7PC"
What am I missing here - the help file and forum search return nothing about using the "Insert Table Column" button. The little pop-up help window on the Regular Expression label states that it should import the _value_ of the column and I do not see that as happening.
Any help is appreciated.

Comments

  • Options
    Hi,

    Thanks for your post. Sorry you have encountered this problem.

    In order for me to produce this, what are the datatypes of the two columns?

    Is your regex expression something like $[Address] ?

    Thanks

    Ben
  • Options
    Hello Ben!

    Yes, the regex is $[Address]
    The datatype of the source column (Address) is varchar(100), is not nullable and is being populated by the Address Line (Street Number) generator.
    The datatype of the destination column is varchar(1000), not nullable and is being populated by the Regex expression which contains $[Address].
    BTW, I have also noticed that adding a FK column to the regex window causes this column in the preview pane to gray out and display what appears to be a lock icon - looks like a link of a chain. Is this expected behavior?

    David
  • Options
    Hi David,

    I just created the following table and that all appears to work as expected.

    CREATE TABLE TempTable(ID INT, Address varchar(100) NOT NULL, Destination varchar(1000) NOT NULL)

    Would it be possible for you to send me your schema and project file so I can attempt to reproduce this on my local machine.

    Which SQL Server version are you running?

    Thanks

    Ben
  • Options
    Hmmmm.....
    We are using Sql Server 2005 SP2.
    I did what you did and it worked for me also. I noticed you had an int ID column, our table is using a GUID as the PK. I also tried it with a GUID PK and it still worked.
    I will send you the schema and project file. I have your email address from a previous interaction. The schema includes some Full-text search SQL which you may wish to comment out rather than try to get it configured to work. I included in the script it so you would know that it exists. The script I will send you was generated with Microsoft's Database Publishing Wizard.
    As always, thanks for the help.

    David
Sign In or Register to comment.