"select *" tab expand does not respect comma placement rule

austrianfoodispukeaustrianfoodispuke Posts: 100
edited August 4, 2008 2:25PM in SQL Prompt Previous Versions
enter ssf * from x

go back to * and hit TAB to expand the cols

commas are placed at the end of the line

my layout setting is to put it at the beginning


  • good point, I just ran into that issue this morning
    not a big blocker though, just means I have to fix either the first few lines, or the last few lines
    Jerry Hung
  • Hi,

    Pressing tab expands the columns in the table and at this point of time it is SQL Prompt's code completion functionality that is at work.
    For your layout settings to take effect, you need to click on Layout option in the SQL Prompt menu and that would format your code as you have customised in your settings.

    I hope that helps.

  • paschottpaschott Posts: 71 Bronze 4
    I'm just curious - wasn't this part of the standard SQL Prompt package at one point and not only available in the Professional edition? I could have sworn that I could do this in an earlier release and as far as I know I've never had a "Professional" edition.

    I was looking for this today as I'm laying out some new code and found all of my commas placed at the end of the line rather than at the beginning as I'd hoped for.


    -Peter Schott
  • This WAS a part of the original Prompt SQL (and possibly SQL Prompt 2.x), but unfortunately not 3.x. It was one of the first things I noticed when 3.x came out.
Sign In or Register to comment.