Competition: What’s your favorite Redgate tool? Enter now.

Changing backup jobs

jamarshajamarsha Posts: 6
edited May 28, 2008 9:18AM in SQL Backup Previous Versions
Hello-

I have several backup jobs running daily. Recently I tried changing the jobs to discard files older than 48 hours, but the changes do not appear to be holding; i.e., when I edit/view the job again, I am not seeing the changes I made.

Thanks!

Jason

Comments

  • Hi Jason,

    Thank you for your post on our forums.

    I am unable to recreate the issue you are encountering, is it possible for you to provide me with some more details?

    What version of the SQL Backup GUI are you using? (Help>About)

    What are you changing the discard files option from?

    What Operating System and Service Packs do have have installed on the GUI machine?

    Thanks
    Matthew Flatt
    Redgate Foundry
  • Hi Matthew-

    we're using 5.2.0.2825, running on a Windows Server 2003 SP2 box. I'm changing the discard option from 2 days to 48 hours, but 3 days worth of backup files are remaining in the folders. When I go back in to edit the jobs, I see 2 days instead of 48 hours in the 'All files older than' boxes...
  • Jason,

    Thank you for your response.

    The SQL Backup GUI will convert all hour entries which are multiples of 24 to be in day format.

    If you change from 2 days to 47 hours, the change should still be apparent when you edit the scheduled job.

    Please let me know if this helps.
    Matthew Flatt
    Redgate Foundry
  • Hi Matt-

    This fixed the problem.

    Thanks!

    Jason
Sign In or Register to comment.