not enough space to run a compare

kevinjgoffkevinjgoff Posts: 4
I'm running out of disk space on my c:\ drive when i run a sql data compare against a large set of tables. Is there a way to configure the sql data compare tool to use a different directory than "C:\Documents and Settings" since my c:\ drive is not very large?

Ideally if I could set the path where these files would go similar to how you can set the script path in the application options that would be perfect. I've got gigs of space on my e:\ but can't seem to be able to use it.

TIA
Kevin :cry:

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hi Kevin,

    You can set the location of the temporary files created by Data Compare if the drive where Windows allocates temporary files is too small.

    If you open a command prompt and type SET RGTEMP=e:\temp, then run RedGate.SQLDataCompare.UI.exe, the session will use e:\temp for temporary files. If you want to make the change permanent for your login, you can right-click My Computer, then properties, then click the advanced tab and click Environment Variables. You can then add RGTEMP you your user settings and log off and on again.

    Hopefully this helps you get a bit more out of the software!
  • If you're using 6.1.1 there is also an option to compress the temporary files during comparison which can reduce disk space by aroung 80%! This is set on a per-project basis from the Options tab in the project configuration window.
    Richard Mitchell
    Project Manager
    Red Gate Software Ltd
Sign In or Register to comment.