What are the challenges you face when working across database platforms? Take the survey
Options

Adding the Verify parameter to an SQL Agent Job

ChrisAVWoodChrisAVWood Posts: 361
edited March 11, 2008 7:15PM in SQL Backup Previous Versions
Hi,

I created my SQL Agent jobs from the SQLBackup 5.2 GUI without checking the Verify box. I am now adding the VERIFY to the job but sometimes the GUI display still shows the verify is still OFF. Are there situations, like too large to verify, where the verify is ignored?

I am using 5.2

Thanks

Chris
English DBA living in CANADA

Comments

  • Options
    Hi Chris,
    Sometimes the VERIFY will return "No" when infact it has either verified successfully, or there was a problem performing the verification. This is due to a bug in the SQL Backup GUI which will be fixed for 5.3.

    If you see an entry appear as "No" when you are expecting a "Yes" value, double-click on the entry in the activity history to view the properties of the backup. If any warnings or errors occurred during the verification, these should be displayed here.

    Hope that helps,
    Jason
  • Options
    That's exactly the situation I am having Jason. I will test 5.3 for this situation when it comes out.

    Thanks

    Chris
    English DBA living in CANADA
  • Options
    I am using SQL backup version 5.3.0.178 and am still experiencing this problem. I have a job that backs up a number of databases and the largest one (60 GB) says it is still "In Progress" and "Finishing" the backup even though it completed about 11 hours ago. When double-clicking on the backup record in the GUI, it states that the backup completed without any errors or warnings.

    So it looks like this issue is not entirely fixed in version 5.3.

    Mike
  • Options
    Eddie DEddie D Posts: 1,789 Rose Gold 5
    Hi michaelfried

    Thank you for bringing this problem to our attention.

    Can you please confirm to me, if you are backing up multiple databases in a single job to a network share?

    In my testing for the fault condition, I can only recreate the problem when the backup job is to a network share.

    Many Thanks
    Eddie

    Eddie Davis
    Red Gate Software Ltd
    Technical Support Engineer
    E-Mail: support@red-gate.com
    Eddie Davis
    Senior Product Support Engineer
    Redgate Software Ltd
    Email: support@red-gate.com
  • Options

    Can you please confirm to me, if you are backing up multiple databases in a single job to a network share?

    In my testing for the fault condition, I can only recreate the problem when the backup job is to a network share.

    Eddie,

    I was backing up a single database to a single file on a local drive. It happened two nights in a row. When I open the GUI now (a week later) the backups statuses say they are complete. I have not seen this issue on a second server that we have running with SQL Backup 5.3.

    Mike
Sign In or Register to comment.