What are the challenges you face when working across database platforms? Take the survey
Options

Possible 3.6 bug

wtjoneswtjones Posts: 21
edited January 15, 2008 2:05PM in SQL Prompt Previous Versions
Type the following:

exec someproc 'abc'

Place your cursor in front of the first single quote and then try to type another single quote.

SQL Prompter will delete the new quote.

Comments

  • Options
    Bart ReadBart Read Posts: 997 Silver 1
    Hi there,


    I'm not sure if this is what you're after, but you can actually modify this behaviour in the Options dialog. Go to SQL Prompt > Options, then Auto Insert > Closing Characters.

    You can either disable auto-insertion of the single-quotation mark entirely (I wouldn't recommend this though) by unchecking "Single quotation mark" under "Define closing characters". You could also try unchecking the "Overtype duplicate closing characters" option.

    Hope that helps.


    Thanks,
    Bart
    Bart Read
    Principal Consultant
    bartread.com Ltd
Sign In or Register to comment.