What are the challenges you face when working across database platforms? Take the survey
Options

Synchronisation Wizard in version 6 keeps crashing.

I'm trying to use the new version 6.0.0.2 but each time I click on the Synchronisation Wizard, it instantaneously crash with a report sent to Microsoft. No problem at all if I use version 5.3. I've tried with both creating a new project or re-using a project from 5.3. Only a few tens of differences are involved in the synchronisation. Machine: WinXP Pro with SP2, Pentium 4, 767 MB or RAM (Dell 8250); all the latest updates from MS applied.

Any idea on what I could check? Thanks!

Comments

  • Options
    This may be a problem we've spotted to do with the SQL Server you're using. Can you check the service pack of your sql server as I believe if it's prior to SP4 there can be problems.

    We will be bringing a point release out soon that will fix the issue.
    Richard Mitchell
    Project Manager
    Red Gate Software Ltd
  • Options
    Hi, the target machine is SP4 (8.00.2039, Desktop Engine, this is the local instance running on my machine (WinXP Pro SP2)) but the source is running SP3, 8.00.760, Enterprise Edition.

    Does your solution relates to the version of the source, the target or to either one of them?
  • Options
    I believe it's just the target machine, so I'm slightly surprised you're seeing that crash.

    Do you have Red Gate SQL Backup installed on the machine, and if so, which version?

    Many thanks,
    Robert
    Robert Chipperfield
    Red Gate
  • Options
    Yes, I had SQL Backup Pro (july 2006) installed on this machine and removed a few weeks ago and SQL Backup 5 installed recently but never used.

    If I remember correctly, I've used SQL Backup Pro (the older version) to make some tests but not with this particular database; it was with another database running on the same instance.

    I'd also used SQL Log Rescue but again not on this database, it was on another one but still both on the same (target) SQL-Server 2000.

    I can try removing SQL Backup 5 (and/or SQL Log Rescue) if you think this might help correcting the problem.
  • Options
    Hi,

    If you're not using SQL Backup, you might want to give it a go for the moment - hopefully the issue should be addressed properly in the patch release of Data Compare (expected early next year, I think), but this should get you running for the moment.

    SQL Log Rescue shouldn't have any effect, so there's no need to remove that.

    Thanks,
    Robert
    Robert Chipperfield
    Red Gate
  • Options
    Hi, just a word to say that I've just removed SQL-Backup (and rebooted) but still no luck, SQL-DataCompare 6 keeps crashing.
  • Options
    Hi,

    Bother - I thought that would've cured it. Do you have access to any other database servers that you could run against as the target? (Obviously not actually performing the synchronization!)

    Do you get any details regarding the crash, or is it just an instant bail out with no further information?

    Sorry this hasn't worked for you so far - and thanks for your help in providing the information!

    Robert
    Robert Chipperfield
    Red Gate
  • Options
    Hi, the crash occurs after the display of the first dialog window of the wizard: it display it's dialog window then after 2 or 3 seconds, the crashing window appears. It looks like that SQL-Compare is trying to access a null record; if I enter the CLR Debugger, I have the following information:

    An unhandled exception of type 'System.Data.SqlType.SqlNullValueException' occurred in System.Windows.Forms.dll

    Additional information: Data is Null. This method or property cannot be called on Null values.


    To my knowledge, there is no further usefull information from the Debugger. If I take a look at the error report (the one to be sent to Microsoft); I have the following content:

    from the Error Report Contents; first window:

    Error Signature:
    EventType: clr20r3
    P1: redgate.sqldatacompare.ui.exe
    P2: 6.0.0.1124
    P3: 4703485d
    P4: system.windows.forms
    P5: 2.0.0.0
    P6: 461ef203
    P7: 150c
    P8: 12f
    P9: desIn42ebwmodxjic4snf0cyehcagzn


    If I click to view the contents of the error report:

    Exception Information
    Code: 0x0434f4d Flags: 0x000000007c812a5b
    Record: 0x0000000000000000 Address: 0x000000007c812a5b

    Module 1
    RedGate.SQLDataC
    Image Base: 0x11000000 Image Size: 0x00000000
    .....
  • Options
    I must add to that that the wizard seems to be working correctly as I can click the buttons and follow the sequence of dialog windows and even perform the final synchronisation step correctly.
  • Options
    Hi,

    Thanks for the information - that's exactly what I was looking for. The reason it'll appear to keep working in the background is that the crash is actually happening in a background initialisation thread, rather than the UI thread.

    Sorry once again for the inconvenience - we'll let you know as soon as we've got a patch available.

    Thanks,
    Robert
    Robert Chipperfield
    Red Gate
  • Options
    Hi,

    Just to let you know, 6.1 is now out. You can get this by going to Check for Updates on the Help menu.

    Robert
    Robert Chipperfield
    Red Gate
Sign In or Register to comment.