SQL Compare 6 - APPCRASH on startup

frankinatlfrankinatl Posts: 5
edited January 5, 2008 11:01PM in SQL Compare Previous Versions
When i start up SQL Compare 6 after installing on Vista Ultimate, I get the following error ... "SQL Compare 6 has stopped working". Looking at the details ...

Stopped working

Problem signature:
Problem Event Name: APPCRASH
Application Name: RedGate.SQLCompare.UI.exe
Application Version:
Application Timestamp: 471df775
Fault Module Name: ntdll.dll
Fault Module Version: 6.0.6000.16386
Fault Module Timestamp: 4549bdc9
Exception Code: c0000005
Exception Offset: 00062086
OS Version: 6.0.6000.
Locale ID: 1033

What can I do to get this application to run under Vista?


  • Options
    I haven't been able to reproduce this ( installs and runs on Vista for me). Could we have some more information about your configuration, please? I'm particularly interested in:

    1) Do you have any source control programs installed, and if so what are they and what version do you have? The most likely reason that I can't reproduce the error is that it only occurs in the presence of a certain version of a certain source control package.

    2) Did you have a version of Compare previously installed on this computer?

    3) Is there anything else odd about your Vista environment that you think we might need to replicate in order to reproduce the problem?

    If I can reproduce the problem, hopefully I can tell you how to work around it and we can make sure that the next release won't suffer the same issue.
    Software Developer
    Redgate Software
  • Options
    I am using a Lenovo laptop with factory installed Vista Ultimate. This install is a clean install ... no upgrade. I am using SourceGear vault version 4.0.2 for source control. You can download the client software from sourcegear.com. I have all the standard dev tools installed - vs2005, sql server 2005, etc. All the other red gate apps run fine. I am using norton internet security for a security and have microsoft virtual pc 2007 installed and some adobe apps ... nothing odd that i can figure out.
  • Options
    What version of ntdll.dll do you have in c:\windows\system32 ... ? My version is 6.0.6000.16386.
  • Options
    That's the version I've got too. I've tried installing SourceGear 4.0.2 but that hasn't caused any problems. I'm working on getting the rest of the stuff you mentioned installed on my test machine to see if the combination does anything.

    Have you tried launching any other Red Gate products (or SQL Changeset, which comes with Compare 6.2)?
    Software Developer
    Redgate Software
  • Options
    As I mentioned earlier all the other red gate apps run fine including SQL Changeset.
  • Options
    I still don't seem to be able to reproduce this problem - I haven't got my hands on Norton Internet Security though, so that might be causing some kind of problem.

    Have you tried all of the standard things like uninstalling and reinstalling SQL Compare / installing it to a different location? You might also want to clean out the %TEMP%\Red Gate\ directory.
    Software Developer
    Redgate Software
  • Options
    One of the developers informs me that this might be some kind of permissions issue. Are you running as a local administrator or a limited user? Are there any unusual limitations on your access to the registry or file system?
    Software Developer
    Redgate Software
  • Options
    I am actually having the same problem as he is.

    I then uninstalled/reinstalled and now it just freezes on startup.
    The process sucks up about 50% of the processor power.

    I have a Vista machine as well.
    Running it as Admin/non-admin makes no difference.
Sign In or Register to comment.