What are the challenges you face when working across database platforms? Take the survey

Suggestion: SQB Service Management in GUI

BryantBryant Posts: 20 Bronze 2
edited November 15, 2007 11:59AM in SQL Backup Previous Versions
I had a problem this morning with the GUI not being able to connect to one of my servers that is running SQL Backup 5.2. I was able to connect with SQL Management Studio but not with the SQL Backup GUI. I finally figured out that the GUI was trying to communicate with the SQL Backup service on the server and not with the SQL Server instance itself.

It would be helpful to know in the GUI that the SQL Backup service is down rather than just showing a generic "can't connect" icon. Additionally, being able to start and stop the SQL Backup service from the GUI would be great.

Just a suggestion from a perfectionist across the pond. :D


  • Options
    peteypetey Posts: 2,358 New member
    The SQL Backup GUI communicates with the SQL Backup Agent service via the extended stored procedures. The extended stored procedures are designed such that if the SQL Backup Agent service is not running, the extended stored procedure will attempt to start the service. If it fails to do that, it suggests that the SQL Server service startup user does not have adequate rights to manage the service.
    Peter Yeoh
    SQL Backup Consultant Developer
    Associate, Yohz Software
    Beyond compression - SQL Backup goodies under the hood, updated for version 8
  • Options
    Brian DonahueBrian Donahue Posts: 6,590 Bronze 1
    Hi Bryant,

    You may have also missed that the GUI does actually have information about the SQB Service state. If the connection fails, and a red X icon sits next to the server name, you can right-click that and select Properties. The properties sheet will tell you plainly that the SQL Backup Agent could not be started or that the attempt to start it has timed out.

    Maybe this information should be presented a bit closer to the surface.
  • Options
    BryantBryant Posts: 20 Bronze 2
    Thanks, I wasn't aware of that but I will remember it now!
Sign In or Register to comment.