JIT: Unable to create or open mutex Local\...ompt_UIOptions

LumbagoLumbago Posts: 32
edited October 26, 2007 9:57AM in SQL Prompt Previous Versions
Every time I try to edit options in SQL Prompt 3.6.0.109 I get this JIT error message and none of the changes I make are saved:
************** Exception Text **************
RedGate.Util.MutexManagerException: Unable to create or open mutex Local\RedGate_SqlPrompt_UIOptions.
   at RedGate.Util.MutexManager.CreateOrOpenMutex(String name)
   at RedGate.SQLPrompt.CommonUI.Options.UIOptions.SaveOptions()
   at RedGate.SQLPrompt.CommonUI.Forms.Option.OptionDialog._2(Object , EventArgs )
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ButtonBase.WndProc(Message& m)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

This makes SQL Prompt virtually useless for me and I have tried to the best of my ability to install and uninstall and nothing seems to do the trick. I have also reinstalled .net framwork 2.0 without it helping much. Every time I close a query window in SSMS I get this error:
************** Exception Text **************
System.Runtime.InteropServices.InvalidComObjectException: COM object that has been separated from its underlying RCW cannot be used.
   at Microsoft.VisualStudio.TextManager.Interop.IVsTextView.RemoveCommandFilter(IOleCommandTarget pCmdTarg)
   at RedGate.SQLPrompt.CommonVS.Managers.EditorManager.OnUnregisterView(IVsTextView pView)

I run SSMS under alternate credentials (Run as...) and here is a short summary of my system information:
OS Name			Microsoft Windows XP Professional
Version			5.1.2600 Service Pack 2 Build 2600
OS Manufacturer		Microsoft Corporation
System Manufacturer	IBM
System Model		26684NG
System Type		X86-based PC
Processor		x86 Family 6 Model 13 Stepping 8 GenuineIntel ~1862 Mhz
Locale			Norway
HW Abstraction Layer	Version = "5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)"
Time Zone		W. Europe Daylight Time
Total Phys. Memory	1 024,00 MB
Available Phys. Memory	243,36 MB
Total Virtual Memory	2,00 GB
Avail Virtual Memory	1,96 GB
Page File Space		2,40 GB
Page File		C:\pagefile.sys

Comments

  • A short update:

    I did manage to update the settings after all but it was sort of akward.

    I uninstalled everything, logged on to Windows as the alternate user (user2), installed both SQLPrompt and Refactor, edited settings successfully, logged out, logged in to Windows again as user1, started SSMS with Run As User2, and then the settings are ok and I can use it just fine.

    However; every time I close a query window in SSMS I still get the error message posted obove here. It is somewhat annoying but since it's not causing any damage it doesn't really matter that much.
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Thanks for writing. I have logged this as a bug (SP-804). If this can't be prevented for security reasons, then at least we should handle it with a bit more grace.
Sign In or Register to comment.