Running data script fails

keymookeymoo Posts: 38
edited November 4, 2007 12:49PM in SQL Packager Previous Versions
Hi,

I have scripted out a database using SQL Packager version 5.4.0.89 against SQL Server 2005 SP2.

I saved the schema and data has two separate SQL Scripts. The schema script runs fine, however the data script gives me this error when I run it:
Msg 102, Level 15, State 1, Server SQLSERVER1, Line 45514
Incorrect syntax near '2'.

My data file is 350MB so I suspect it has something to do with the size of the file. Is there any way to put GO statements in every n number of rows? Do you think inserting GO statements will solve the problem?

Thanks,
keymoo

Comments

  • I managed to eliminate this problem by reducing the amount of data I script out. I have saved the data as a set of INSERT statements directly from SQL Packager.

    If I run this file into my SQL 2005 SP2 server using sqlcmd.exe I get this error:
    Msg 701, Level 17, State 123, Server SQLSERVER1, Line 25719
    There is insufficient system memory to run this query.
    
    Any ideas how to fix that one?

    Thanks
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hi,

    This looks to be a complex problem with a multitude of causes. Microsoft cover this on their Technet site, but there doesn't seem to be a clear solution except to increase the server memory or clear out some of SQL Server 2005's caches ie DBCC FREEPROCCACHE.
Sign In or Register to comment.