What are the challenges you face when working across database platforms? Take the survey

Installation failing on SVC Account security error

mdgravesmdgraves Posts: 53
edited October 12, 2007 8:04AM in SQL Backup Previous Versions
I am installing v5.2.0.2807 on default instance of SQL 2000 SP-4, Win 2000 SP-4.

Install comes up and asks for "Select Service Application Startup Account". I use same SVC Account that SQL and SQL Agent use. I am logged onto server as the SVC Account as well. Following is message that comes up....

""The user name and password failed to be validated. Error (A required privilege is not held by the client)""


  • Options
    Unfortunately, there is an issue with Windows 2000 (up to and including SP4) that causes problems when trying to validate the correct privileges for a user - in this case, the Server Components checking for the "Log On as Service" privilege. As a result it's not possible to complete the installation without using the "built-in account" to avoid that check.

    There are two ways around this:

    * Use a built-in account for the SQL Backup Agent (will definitely work).

    * Install as a built-in account, then change to use another account (should work, but Windows 2000 is a bit flaky in this area):
    - Using the "Local Security Settings" tool under Administrative Tools, find the "Log On as a Service" option (should be in a section called "Local Policies", "User Rights Assignment")
    - Add the account in question.
    - In the "Services" tool, change the SQL Backup Agent settings to use the account you wish to use.
    - Attempt to start the service (which should work). If the service fails to start, there could be other missing credentials that the service may require.

    If you use the second option and the above doesn't work, let us know and I'll look into it further for you.

  • Options
    I used your option #2, as the Svc Account was already defined since in use as SQL and SQL Agent account. I reconfigured in SERVICES without issue.

    One can only hope Microsoft is aware of this odd behavior.

    Thanks for help.
Sign In or Register to comment.