problem with SQLServer named instances

DbguruDbguru Posts: 5
edited October 23, 2007 10:50AM in SQL Compare Previous Versions
Hi,
I am playing with SQLCompare 6 ,I found a problem in connecting the SQLCompare with SQLSever Named Instance.
eg: <machine_name>\<instance_name>
It throws an error which describes that the connection string is invalid
Does Redgate SQLCompare support the NamedInstance?

Thanks
DBguru

Comments

  • Hi there,

    SQL Compare should not have any problems with named instances. Two of our three test servers are named instances and we have not had any problems with them.

    Are you just using machineName\instanceName or are you entering a connection string in the Server combo box?

    I take it you have not had any problems using Query Analyser or Management Studio?

    Can you post the error message?

    Regards,

    Jonathan
    Jonathan Watts

    -Project Manager
    -Red Gate Software Ltd
  • Hi,
    Thanks for your reply.The problem is with my machine ,i haven't configured the SQLServer installed machine to be allowed to connect with remote client(TCP/IP) so was the problem.Now it is ok with SQLCompare 6.
    Thanks a lot!
  • I am getting errors with named instances using the cmd line version
    Serial Number:xxxxxxxx

    Registering databases
    Creating mappings
    Comparing
    Replaying user actions
    Creating SQL
    Synchronizing databases
    Error: Error Comparing ark01aesmdata02/AESM vs ark01aesmrep02\reports/AESM_REP :Incorrect syntax near '\'. Incorrect syntax near '\'. Incorrect syntax near '\'.Incorrect syntax near '\'.

    This error just popped up. We have been using the same instances for months, but with version 6, i am getting this error. It works fine with default instances.
  • Here is the cmd line we are using if that helps any
    utils\SQLCompare.exe /out:utils\SQLCompare.log /force /server1:ark01aesmdata02 /database1:AESM /username1:sa /password1:xxxxxxx /server2:ark01aesmrep02\Reports /database2:AESM_Rep/username2:sa /password2:xxxxxxx /synchronize /options:IgnoreTriggers
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hi BJ,

    This looks to be more of a command-parsing error. Have you tried enclosing all of your arguments inside double-quotes?
  • Hi BJ,

    This looks to be more of a command-parsing error. Have you tried enclosing all of your arguments inside double-quotes?

    I have not tried that. I will try today and let you know. Thanx for the suggestion.
  • BJ wrote:
    Hi BJ,

    This looks to be more of a command-parsing error. Have you tried enclosing all of your arguments inside double-quotes?

    I have not tried that. I will try today and let you know. Thanx for the suggestion.

    just for a reference, I went and looked at a log file from last week when it actually worked.

    DB1 = ark01aesmdata02.AESM
    DB2 = ark01aesmrep02\reports.AESM_REP

    it was seperating the DBName from the Server with a "." instead of "/"
    which is what it is doing now. Can you think of anything that might have made this change? or a way to set it back to use the period?
Sign In or Register to comment.