What are the challenges you face when working across database platforms? Take the survey
Options

Failed backups

Giggles220Giggles220 Posts: 154
edited October 9, 2007 9:47AM in SQL Backup Previous Versions
I have a problem with the full backup for 1 database on each of 2 different servers failing. The only thing I can figure is that it is the largest database on these two servers. It appears to write the file to the primary location (despite the error message) but does not write the file to my copyto location. Any help is appreciated.

Error message:
10/4/2007 8:20:50 AM: Backing up FIPSOlap (full database) on BIPRODUCTION instance to:
10/4/2007 8:20:50 AM: \\mscotda0a1am\sqlback\mscotda0a1azBIProduction\FIPSOlap\FULL\FIPSOlap_20071004_0820.sqb

10/4/2007 8:20:50 AM: BACKUP DATABASE [FIPSOlap] TO DISK = '\\mscotda0a1am\sqlback\mscotda0a1azBIProduction\<database>\<type>\<AUTO>' WITH NAME = '<AUTO>', DESCRIPTION = '<AUTO>', PASSWORD = 'XXXXXXXXXX', KEYSIZE = 256, ERASEFILES = 43, MAILTO_ONERROR = '_sqlpsqi@dfa.state.ny.us', COPYTO = '\\stbfs93brdwy\sqlback\<server>biproduction\full\<database>\', COMPRESSION = 2

10/4/2007 8:23:14 AM: Thread 0 error:
Error 620: Error writing to backup file(s).
10/4/2007 8:23:14 AM: Warning 210: Thread 0 warning:
Warning 210: Error writing to backup file: \\mscotda0a1am\sqlback\mscotda0a1azBIProduction\FIPSOlap\FULL\FIPSOlap_20071004_0820.sqb
Warning: System error 64 (The specified network name is no longer available) Processed 238936 pages for database 'FIPSOlap', file 'FIPS' on file 1.
Processed 4 pages for database 'FIPSOlap', file 'FIPS_log' on file 1.
BACKUP DATABASE successfully processed 238940 pages in 143.636 seconds (13.627 MB/sec).

Settings:
max. Transfer Size 640
Max data block 3712
compression lvl 2
encrypts backup
copies to network folder.

Comments

  • Options
    Brian DonahueBrian Donahue Posts: 6,590 Bronze 1
    Hi Heather,

    The most common things to look into are DNS and network latency issues. You can use the NSLOOKUP utility to make sure that's working, although there is no guarantee that there still isn't some DNS problem during transfer. So checking the application and system event logs for DNS failure may help.

    You may also try setting the NETBIOS protocol timeout to a higher number if the network is slow. To do this, set the registry key:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanworkstation\parameters\SessTimeout=00000384
  • Options
    Thanks for the reply. I will attempt to change the registry setting. I have several other databases on these 2 servers and they all have no problem backing up. I will let you know what happens once the registry setting is changed and I have ran a backup.
  • Options
    We changed the setting on one of the servers and I ran it during the day and it worked. We are going to let it run this weekend as scheduled to verify that it is truly fixed before changing the registry on our Cluster.
Sign In or Register to comment.