SQL Compare 6: error registering databases

emoreauemoreau Posts: 55 Bronze 2
edited October 23, 2007 9:24AM in SQL Compare Previous Versions
I just updated to SQL Compare 6 (from SQL Compare 5).

I had some comparison projects that were working in version 5 that appeared automatically in version 6.

When I try to compare I receive the error:

An error has occured while establishing a connection to the server. When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Named Pipes Error, error: 5 - Invalid parameter(s) found)


Some details:
-The data source type is al live database
-My server name is using a port (\\aiw506\soxdb_03,1307).
-I use Windows authentication

If I try to create a new project and enter my server name and click the database combo, I receive the same error.

Again, exactly the same settings are working with SQL Compare 5.

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hello,

    Just to verify something, are you entering the double-backslashes in the server name, as in the example from the last post? These shouldn't be there: just the name of the server (and \instancename if it's a named instance). If you could enter a UNC-like path for the server in SQL Compare 5, it really shouldn't work.
  • emoreauemoreau Posts: 55 Bronze 2
    That was it. Thanks for the very quick reply.
  • I have the same problem...registration to a remote SQL Server works fine in SQLCompare 5...fails to register in my new SQLCompare 6 with "timeout" error. I have both versions on my administration machine.

    SQLCompare version = 6.1.0.53

    I have only a server name in the server name field (no slashes or ports)

    Is there a timeout parameter I can lengthen?
    Works fine to other servers in my workgroup...just a time-out on the live server!

    Thank you!
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hello,

    Are you experiencing a connection timeout or a query timeout? Connection timeouts are easy to fix by fudging a timeout into the server box (and therefore it ends up in SQL Compare's connection string), for example:

    Server= MyServer\Instance;Connection Timeout=600

    The actual query timeout is hard-coded, but is something ample like ten minutes long. So if the program is timing out during registration, the communication problem needs to be analyzed because there is nothing you can alter in SQL Compare to extend the query timeout.
  • Excellent suggestion Brian !

    Adding ";Connection Timeout=600" after our server name did the trick !

    Thank you.
    I owe you a pint.

    Cheers.
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Thanks! I could use one or several of those right about now. :-)
  • I am having the same problem with SQL Compare 6. I added ";Connection Timeout=600" after the server name in both databases but SQL Compare can not establish the connections.

    There is no problem connecting to the SQL servers through MS SQL Enterprise Manager, though I had to reconnect several times to establish the connections. Why I hoped that rising the timeout would do the trick, but it did not unfortunately.

    I can ping the servers, they run on default port 1433, and they allow remote connections.

    Any suggestions?

    The LAN is connected through a Cisco Systems VPN Client. Could this be a problem? (Though EM has no problems with this) Walkarounds?
  • Forgot to mention:

    The LAN is connected through a Cisco Systems VPN Client. Could this be a problem? (Though EM has no problems with this) Walkarounds?
  • Also: None of the remote servers has Framework 2.0 installed, but this would not be a requirement?
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Framework 1.1 is the requirement, but it has a number of bugs in the SQL libraries. That's why sometimes changing the app.config file to use the 2.0 runtime solves the problem. There seems to be some change in the way SQL Compare 6 works, so if changing to Framework 2.0 doesn't help then we need to open a support case and deal with you individually. I don't think the matter is as simple as the timeout that the error says you are getting: I think it's happening because the .NET SQL Client is trying to connect with the wrong library, or is misconfigured.
  • Thanks for quick reply!

    Just to be sure we understand each other: The computer I work on has both 1.1 and 2.0 framework. The SQL servers probably has none. The requirement for Framework 1.1 is that for my computer or does it apply for the remote ones also?

    One of the remote computers is critical and on customer site. It is risky to install frameworks on this computer. The other remote computer is old and is short of disk space so installing frameworks on this one would probably make it unusable.
    So if the requirement is 2.0 on the remote ones I guess I can't work around this?
  • Remember now: I ran SQL Compare 6.0 to the customer site computer for a couple of weeks ago and this ran smoothly... puzzles me.
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Sorry -- actually v6 runs on Framework v2. The previous version was 1.1.

    I'll get in touch with you via email.

    Thanks.
  • Problem solved:

    I used Remote Desktop to install the SQL Compare 6 on a third computer inside the customers firewall. This solved the problems for me and I could do what I wanted to.

    But for further knowledge, is there a known problem on connecting through a VPN-client?
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Nothing should be different except that you introduce more failure points. I have noticed that using TCP is more reliable than named pipes through a VPN, so possibly adding a TCP: in front of the server name may help.
  • sorry, tried that also but it did not help me
Sign In or Register to comment.