Compare 6 can not be used in 'Run As' mode -

LurkingShadowLurkingShadow Posts: 4
edited September 20, 2007 7:00AM in SQL Compare Previous Versions
I have just upgraded from v5 which allows 'Run As' mode.

I log on to pc and program with standard network username and password, but to access SQL database and code I have to use a special SQL admin username and password. With the 'Run As' option this was fine, I could login to Compare with my SQL admin username.

Now I am locked out. Is this feature now removed or did I install something wrong or is this a bug?
Lurking Shadow

Comments

  • Hi there,

    Sorry about the problems you are experiencing.

    Which OS are you using?

    I have had a quick look into this on Vista and XP, whilst XP appears to be fine and authenticating correctly, Vista does appear to be ignoring the Run As command. So it looks like there is an issue there somewhere.

    Regards,

    Jonathan
    Jonathan Watts

    -Project Manager
    -Red Gate Software Ltd
  • Using XP sp2

    I still have v5.3 installed and this still allows 'Run As' so I don't think its the op system, may be the way it was installed?, although I have admin rights to the pc
    Lurking Shadow
  • The only difference I can see between v5.3 and v6 on XP in Run As behaviour is that the "Run As..." right click context menu option does not get displayed by default on v6. You have to hold shift down and right click, rather than just right clicking.

    Is the problem that you cannot see the Run As menu option for v6 or that it isn't authenticating correctly?

    Regards,

    Jonathan
    Jonathan Watts

    -Project Manager
    -Red Gate Software Ltd
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hi guys,

    I had logged this as an issue late last week. I think it has to do with the type of shortcut (.lnk) file in the setup, which seems to enforce the old Windows 2000 behaviour for shortcut icons.

    You can get to the RunAs and other right-click context menu items by using shift+right-click.
  • That I cannot see the option and if you right click on the menu item, then, properties, then shortcut tab, advanced button , the 'Run with different Credentials' is greyed out.

    The shift down and right click still brings up the 'run as'
    Lurking Shadow
  • Cheers Brian,

    I will have a word with the installer developers and see what we can do about getting proper links.

    Regards,

    Jonathan
    Jonathan Watts

    -Project Manager
    -Red Gate Software Ltd
Sign In or Register to comment.