No results on IIS6 when some assemblies are in GAC

Setup: Web service running in IIS6. Some assemblies are located in the bin\ subdirs of the virtual directory, some are in GAC. Where should I put the pdb files? I have tried C:\WINDOWS\system32\inetsrv and the bin dir under the virtual directory but ANTS does not pick up any results at all.

(msg in snapshot view is: "No .NET methods have been profiled", and I am profiling only methods with source code)

It is a debug build, web.config has system.web/compilation/@debug="true".

It would be really nice to be able to specify a (or several) symbols directories from the UI.

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Thanks for your post. The rule of thumb is that the PDB should be in the same folder as the assembly being loaded by the runtime. This makes profiling assemblies kept in the GAC a little tricky when you want to use the 'profile only methods that have source code' option.

    What you want to do is locate the 'real' folder that the assembly is stored in in the GAC folder, but good the old fusion.dll shell extension makes it impossible to navigate past %systemroot%\assembly using explorer. So you basically have two options:

    - Unregister fusion.dll (regsvr32 /u fusion.dll) and find the folder containing the version of the assembly you have a pdb for and copy the pdb there using Windows Explorer, then re-register fusion (regsvr32 fusion.dll).

    -Use the command prompt and try to locate the folder using DOS commands and use the copy command to put the pdb into the appropriate folder.

    Once the pdb is there in the same folder as the dll, ANTS Profiler will work the same way with a GAC assembly as one in the local folder.
  • Now there's something I never knew you could do before! :-)

    I also found I needed to unregister shfusion.dll (in C:\Windows\Microsoft.NET\Framework\v1.1.4322) before it took effect...

    Cheers,
    Rob
    Robert Chipperfield
    Red Gate
  • besides IIS? I still get no results, even if I choose to profile all .NET methods. I have used the cmd line approach.


    Best regards,
    Mikkel
  • Ignore my last post, the ANTS service had been killed for some reason, I'll just try it again...
Sign In or Register to comment.