Restore Issue

thomascroththomascroth Posts: 17
edited September 17, 2007 10:51AM in SQL Backup Previous Versions
I'm trying to restore a database. I'm in the process of installation, configuration and testing of 5.1.0.2781 on one of my production servers. I have previously configured 3 other production servers with 5.1.0.2781 and have had no problems testing the restore option.

On this server, I get to a point where I'm not allowed to proceed. I'm trying to restore a database to a new database. On the "Restore Wizard" step 2 of 4 (Select the destination database) screen, I select "Create New Database" and enter a new db name. I have the following message which I've never seen before on any of the other servers: "One or more database file names contain invalid characters, such as \ / :*? <>|".

The database name is: RothCentral
The file group is: C:\SQLBak
Primary: RothCentral.mdb
Transaction: RothCentral.ldb

The only active buttons at this point are: Back and Cancel. I can not select the "Next" button.

Any assistance would be great!!!

Thanks,

Tom
Tom

Comments

  • [update]This will also be included in the forthcoming 5.2 release, so the solutions below should only be used if using versions 5.0 or 5.1[/update]

    As a follow-up to this issue, the reason for the problem is that the value of "SQLDataRoot" (in the SQL Server portion of the registry) contains an additional backslash at the end than it should do. This is causing confusion for the GUI which expects this value to be of the format defined by SQL Server.

    We hope to have this fixed in a future version of SQL Backup, but at the moment there are two options:

    1) The "fix" is to change the registry key SQLDataRoot, which will be:

    For SQL 2000 on a 32-bit server, under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\Setup

    For SQL 2000 on a 64-bit server, under HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\MSSQLServer\Setup

    For SQL 2005 on a 32-bit server (or 64-bit SQL 2005 on a 64-bit server), under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL.#\Setup (where # is the instance number)

    For 32-bit SQL 2005 on a 64-bit server, under
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Microsoft SQL Server\MSSQL.#\Setup (where # is the instance number)

    Removing the final backslash from the location will resolve the problem, for example:
    c:\program files\microsoft sql server\mssql.1\mssql\
    
    would become:
    c:\program files\microsoft sql server\mssql.1\mssql
    

    2) Alternatively, the workaround is as follows:

    * Click the "..." button to the right of the "File Groups" label (the top one in the filegroups and files list).

    * The "Folder" browser comes up, click OK.

    Now proceed to use the wizard in the regular way. If the message appears when switching to "Create new database", repeat the above steps.

    This causes the data directory to be "corrected" internally (even though visibly the directory location is correct) , and will then function correctly in the restore wizard.

    If you need further assistance with this issue, you can contact the Technical Support team at [email protected]

    Thanks,
    Jason
Sign In or Register to comment.