What are the challenges you face when working across database platforms? Take the survey
Options

Failed to initialize local data store: Access to the data...

skweeskwee Posts: 3
edited July 17, 2007 8:41AM in SQL Backup Previous Versions
Hello,

I have problems to install the server components and followed some hints from this forum.

I had to manually run SQBServerSetup.exe

I have checked that the xp_sqlbackup.dll is in place and the extended stored procedures are registered.

I have checked that sqlceoledb30.dll is in place and is registered.

When I try to connect the server from the GUI I still get an error message (in the GUI)

Failed to initialize local data store: Access to the database file is not allowed
[Filename=C:\Documents and Settings\All Users\Application Data\Red Gate\SQL Backup\Data\(LOCAL)\data.sdf]

And the file mentioned in the message is simply not there.

The setup is w2k with sql2000 SP4.
The installation worked fine on a second machine with the same setup.
How can I trigger the generation of data.sdf during the installaton process ?

regards

Steve

Comments

  • Options
    peteypetey Posts: 2,358 New member
    Does the C:\Documents and Settings\All Users\Application Data\Red Gate\SQL Backup\Data\(LOCAL)\ exist? If not, I think it may be that the SQL Backup Agent service startup user does not have rights to create files/folders in the C:\Documents and Settings\All Users\Application Data folder.

    Also, the sdf file is created (if it does not already exist) everytime you start the service.
    Peter Yeoh
    SQL Backup Consultant Developer
    Associate, Yohz Software
    Beyond compression - SQL Backup goodies under the hood, updated for version 8
  • Options
    Thank you, your tip on access permissions solved the problem
  • Options
    I am having similar issues when installing 5.1 on our server. I haven't experienced these in the past with the other servers I've installed Red Gate Backup on. Just for background information, this is on a clustered server, but simply trying to install it on the active node locally for testing.

    I manually added the service account that SQL Backup Agent is running under to have modify permissions on the following folder:

    C:\Documents and Settings\All Users\Application Data

    Once I install the software the service fails to start automatically (which right here is a flag for me). I can start it manually without any issue.

    I see no Red Gate related folders installed in C:\Documents and Settings\All Users\Application Data either, which leads me to believe that something isn't secured correctly on my end.
  • Options
    peteypetey Posts: 2,358 New member
    If you run a backup via QA/SSMS, are any warnings raised?
    Peter Yeoh
    SQL Backup Consultant Developer
    Associate, Yohz Software
    Beyond compression - SQL Backup goodies under the hood, updated for version 8
  • Options
    We just installed the servers so I haven't tried running a normal backup yet, was simply trying to get the RedGate software installed. Let me try to run just a normal backup database to see if that works ...

    Here is the error I'm getting with the RedGate product, after install (when I try to register the server).

    "Failed to initialize local data store: Access to the database file is not allowed. [File=<path>\data.sdf]"

    Which that file does not exists, so I'd imagine it would be an ACL issue.

    Bah disregard, once i gave permission to the service account to that particular folder, it worked fine. I gave it to the "C:\Documents and Settings\All Users\Application Data " as shown in previous messages. Sorry about that.[/img]
Sign In or Register to comment.