Column in table not being compared

I have a table with three columns. Both tables in each database has been synchronized with SQL Compare and are exactly the same. One column is a primary key id field, one is an ntext field, and the last is a varchar(50) field. The varchar field is not being compared in SQL Data Compare so I have one table with values in the varchar field and the other with nulls but SQL Data Compare say the two are identical.

Any ideas?

Comments

  • Hi,

    This can happen if you Data Compare, then add a new column to both tables and then Data Compare again. The reason is that it remembers what columns you have selected for a comparison per table and thus a new column is not going to be part of that list.

    You can remedy this by selecting the column by clicking the "columns" column in the grid on the "select tables and views" dialog.
    Chris Sampson
    Support Engineer
    Red Gate Software
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hello,

    Thanks for the suggestion. The only time you should need to verify the column settings, though, is if you had added new columns since the last compare, because in that case they would not be selected by default.

    It may also be helpful for your peace of mind if you save the settings as a Data Compare project so that you can re-use the selection of columns that you've chosen to compare.
  • This product is great. I have used the trial extensively since I got it. The only cause of the frustration is the product "remembering" the columns to compare and not adding new columns. It would be huge if you would add an option "include new fields atomcatically" or something along those lines.
This discussion has been closed.