What are the challenges you face when working across database platforms? Take the survey
Options

Can't install evaluation on Windows Server 2003 64bit?

mikebridgemikebridge Posts: 19
edited July 9, 2007 12:41PM in SQL Backup Previous Versions
Hi-

I was able to get the evaluation for SQL Backup (version 5.1.0.2781) working without any problems on my 32-bit XP machine with SQL Server 2005 SP2, but I can't get it to install properly on 64 bit Windows Server 2003 SP2 with SQL Server 2005 SP2 (also 64-bit).

When I click on "Install or Upgrade Server Components" to set it up, it fails on "Start SQL Backup Agent Service" (and subsequent steps) with the error "Could not find stored procedure 'master..sqbutility'". After reading the forum, I copied xp_sqlbackup.dll to the proper directory (from my successful 32-bit machine's installation---it didn't exist on my 64-bit machine) and registered it using sp_addextendedproc, but now I get the error "Could not load the DLL xp_sqlbackup.dll, or one of the DLLs it references. Reason: 193(%1 is not a valid Win32 application.)."

Has anyone gotten the evaluation working on a 64-bit machine? Or is it only the deployment version? And does anyone have any experience using the licensed version in 64 bits?

Thanks!

-Mike

Comments

  • Options
    peteypetey Posts: 2,358 New member
    There is a setup file that you can use to install just the server bits. The file is named SQBServerSetup.exe. You should find this file in the SQL Backup installation folder on your 32-bit machine. Copy this to your 64-bit server, and run it.

    You cannot use xp_sqlbackup.dll from the 32-bit machine, as different versions of that file exists for different platforms (32-bit, 64-bit and IA64).
    Peter Yeoh
    SQL Backup Consultant Developer
    Associate, Yohz Software
    Beyond compression - SQL Backup goodies under the hood, updated for version 8
  • Options
    Hi-

    Ok, running SQBServerSetup.exe manually seems to install the proper version of the DLL. I was able to get it running after this.

    Thanks!

    -Mike
Sign In or Register to comment.