What are the challenges you face when working across database platforms? Take the survey
Options

Cannot restart SQL Backup service

FrancoisFrancois Posts: 3
edited June 11, 2007 1:22PM in SQL Backup Previous Versions
Hello,

This weekend, four backup jobs failed (3 days in a row) on our production server. Each of them produced the following error message:

“SQL Backup job failed with exitcode: 5160 SQL error code: 0 [SQLSTATE 42000] (Error 50000). The step failed.”

This error codes refers to “Error acquiring mutex: <value>” in the product documentation. When I manually tried to start these jobs, 2 of them worked, and two of them failed with that same error message. After starting again the job that failed twice, they finally worked.

In order to reduce the risk of this happening again this night, I tried restarting the “SQL Backup” service, but it won’t restart. Here’s the error I am getting in Event viewer when trying to restart the service:

“SQL Backup Agent startup error: error initialising IPC objects. Error creating mutex (already exists): Global\SQBMutex_”

SQL Backup version: 4.6.0.815 running on SQL Server 2005 SP2

Any pointers? Thanks for helping!

Francois.

Comments

Sign In or Register to comment.