CLR error: 80004005

laurencerookslaurencerooks Posts: 28
edited May 31, 2007 2:21PM in SQL Backup Previous Versions
I successfully installed SQL Backup v5 on Windows 2003 Server Standard Edition, but am unable to launch SQL Backup v5. Each time I try, I get the following error:

CLR error: 80004005.
The program will now terminate.


I've tried logging off and on without any success. Has anyone seen this before?

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hi Laurence,

    This looks suspiciously like a COM error. Most .NET methods eventually call COM objects to do the work. It would be nice to know which one! Is there anything in the Application Event Log (eventvwr.exe)?

    I suppose the first thing you could try would be to uninstall/reinstall SQL Backup console. This may shake any pre-compiled code that .NET has cached to speed up the program's loading process. This pre-compiled code might have become invalid. Another reason is that any necessary COM objects could have unregistered for some reason.
  • Brian,

    I tried uninstalling and reinstalling SQL Backup to no avail. I still get the same error message. This is on a server that I have to give good reason for rebooting. Do you have any other suggestions outside of restarting the server? Thanks.

    P.S. - There aren't any errors in the event view, either for Application or System.
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    I wouldn't think that restarting the server would help -- it's a windows issue rather than a SQL issue.

    Maybe you can try this trick:
    c:\windows\microsoft.net\framework\v2.0.50727\ngen c:\program files\red gate\sql backup\RedGate.SQLBackup.UI.exe
    
  • Brian,

    There isn't a framework folder within the .Net folder. Could that be my problem? I checked the add/remove programs and .Net 2.0 is listed as installed. Do I need to reinstall .Net 2.0? Or would going to Windows Update solve that problem for me? I'm still on Service Pack 1 for Windows 2003 Server. Should I move to Service Pack 2?
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    I'd recommend getting the .NET Framework redistributable from Microsoft and reinstalling the 2.0 Framework:

    http://www.microsoft.com/downloads/deta ... layLang=en
  • Brian,

    Reinstalling the .NET 2.0 Framework worked. Thanks!
Sign In or Register to comment.