Error: Nothing to compare.

muralimurali Posts: 3
Hello All,

I am having a problem while comparing two tables owned by different users on different databases on different servers when running from command prompt.

Here is the query I am trying.

sqldatacompare.exe /server1:srv1 /server2:srv2 /database1:db1 /database2:db2 /username1:sa /password1:pwd /verbose /include:Table /include:Table:tbl_test /sync

And here is the output from SQLDataCompare.

Red Gate SQL Data Compare Command Line Utility V5.3.0.81
==============================================================================
Copyright c Red Gate Software Ltd 2004-2006

Serial Number:601-002-061328-5800

SQL Data Compare running with SQL Option: Default (OK).
SQL Data Compare running with Mapping Option: Default (OK).
SQL Data Compare running with Comparison Option: Default (OK).
Comparing database srv1.db1 with database srv2.db2...
Registering databases
Mapping
Error: Nothing to compare. Are you using include / exclude rules that are too constraining, or running with case-sensitivity enabled using rules that would only match objects when running with case-insensitivity?

Any help is greatly appreciated.

Thank you,
mm.

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hi,

    Thanks for asking. This command line you have should work properly. My guess is that the tables can't be automatically mapped. Have you tried running SQL Data Compare (the user-interface version) and comparing the databases with that, and see if tbl_test turns up in the 'objects that cannot be compared' section?

    You could manualy map the table using SQL Data Compare, but I'm sorry to say the manual mapping capability doesn't exist in the command-line. This would require you to add a primary key or unique index onto one of the columns of tbl_test.

    I hope this helps!
  • Thank you Brian, as you said I have found it the hard way. This works with the user interface I have to manually map the columns. Once I did that this worked so I have to create a project and execute the project from command line.

    Murali.
Sign In or Register to comment.