What are the challenges you face when working across database platforms? Take the survey
Options

MAILTO error

mfmf Posts: 26
edited May 29, 2007 10:05AM in SQL Backup Previous Versions
Hi,

I've an issue on ALL the new installations I've done of SQL Backup 5.
They ALL fail on sending mail on error/completion. All old installations that have been upgraded work fine, but none of the new installations.
The new installations are all sql server 2005.
On all of them Database mail has been setup and are working when tested.
SQL Backup 5s mailsetup has also been done and tested OK from the GUI.

But every single job I schedule that try to send mail on completion or on error fails with this in the log:
Warning 151: MAILTO error: Failed to send mail. (5.7.3 Authentication unsuccessful. )

Any ideas?

-Magne

Comments

  • Options
    A small correction, I see now that some of the old installations that have been upgraded also fails on mail sending, but not all of them.
    They all use the same account for mail sending, and all of them send mail perfectly when tested from the SQL Backup GUI Options for setting up mail.

    Testing backup from the GUI also fails with the same message on mail sending.

    So, to summarize:
    Mail sending from the mail setup in the GUI works for all servers
    Mail sending from the scheduled jobs or from the Backup in the GUI fails for some
    All use the same smtp server/account++

    -Magne
  • Options
    Some more information to add to the confusion:

    On one of the servers that mail WORKED on yesterday I still went in and checked the email options. Test failed due to authentication. I punched in the correct password (it hadnt been touched since long before the upgrade to v5, and has worked all the time), test sent email from the GUI. Worked fine.
    Started the job on the server. It failed with exit code 151!!!!!!!!!!!

    Something seems to be really sick....

    ..help? :)
  • Options
    peteypetey Posts: 2,358 New member
    The email settings are stored under the registry key HKEY_LOCAL_MACHINE\Software\Red Gate\SQL Backup\BackupSettingsGlobal\<instance name> on the server. The relevant keys are SMTPHost, SMTPPort, SMTPUserName, SMTPPassword and SMTPSender.

    On a server where MAILTO is failing, could you pls compare the values of the above keys, when set up using the version 4 GUI and the version 5 GUI? Thanks.
    Peter Yeoh
    SQL Backup Consultant Developer
    Associate, Yohz Software
    Beyond compression - SQL Backup goodies under the hood, updated for version 8
  • Options
    Hi,

    I did a upgrade to test and check the settings you asked for.
    1: v4 - Everything worked, saved registry
    2: upgraded to v5 - Ran the same job, everything worked, saved registry
    3: Tested to send mail from the GUI, failed with authentication unsucsessfull, wrote the same passord as had been there before and tested again, mail worked from the GUI
    4: Ran the same job again, FAILED on mail send with authentication unsucsessful, saved registry

    I then compared the 3 registry files I had saved. Everything except the password were identical. In step 1&2 the password was identical, but in step 4, which was after I had added the same password, there was 1 slight difference in the ending of the password.

    I then did another test on another server.
    While on v4 i set the password for email to REDGATE in the registry this became: ’T"G‚EE
    I then upgraded to v5, password in registry: ’T"G‚EE
    I then went into the GUI, and typed in PASSWORD in the password field, and then checked registry: <SQUARE>T"G<SQUARE>‚EE
    <SQUARE>=couldnt cut'n'paste this value, but it is this square box kinda symbol, that you sometimes see if you open a .exe file in a text editor or such. Or when I look at the preview of this posting, there are a few of those "boxes" below here, between the , and <:


    &#130;<


    I tried cut'n'paste the encrypted password from a server that workes into a server that fails, that solves the problem of mailsending, as long as I dont try updating in the GUI again. ;)

    So, it seems like it is the GUI that messes up the password....

    -Magne
  • Options
    &lt
  • Options
    There, the message above shows what i try to explain as <SQUARE> :)
  • Options
    There is an issue in version 5 where if the email options for a server are updated, the SMTP Password field is incorrectly encoded.

    We will fix this in the next version (post 5.1) but in the meantime if this is an issue for anyone else we have a small application which can be used to reset the SMTP password used by SQL Backup.

    Please send me a private message if you require this application including the details of where to email it.

    Regards,

    Helen Joyce
    Project Manager
    Helen Joyce
    SQL Backup Project Manager
    Red Gate Software
Sign In or Register to comment.