Verifying Backups

Giggles220Giggles220 Posts: 154
edited June 25, 2007 6:36AM in SQL Backup Previous Versions
I have selected the option to verify my backups. I was expecting the verify column to display either Failed or Yes. Instead some say No. There are no errors reported though. It appears that some of my databases aren't being verified even though I have the option selected.

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hi,

    Is this the result of a scheduled backup job for backing up multiple databases? Please also let me know if you are looking at the activity history for all databases -- is the verification not happening on one particular database or does it just seem to be at random?

    Thanks!
  • Yes it is backing up multiple databases in the job. I am looking at the history for all databases and it doesn't verify only a few. I do not see a pattern and this is not happening on all servers. The only thing I can say with any confidence is I have not seen it happen with log backups only diffs and fulls
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Thanks for the information. This appears to be a bug in SQL Backup. If you perform a backup, and the maxtransfersize needs to be automatically-adjusted by the software, the restore may fail unless the correct maxtransfersize is also specified. SQL Backup doesn't pass on the change in maxtransfersize, so the restore VERIFYONLY fails.

    This will be addressed in SQL Backup 5.1. Thanks again for your help.
  • This is not fixed in 5.1. It doesn't return FAIL either indicating a failure,it says NO.

    according to your own documentation: If you chose to verify a backup, Verified displays Yes if the backup files are not corrupted and can be read by SQL Backup for restoring or Failed if any of the backup files are corrupted. If you did not verify the backup, No is displayed.

    Since you are saying that the verifyonly is failing I would expect it to report a failure.
  • Hi,

    Thanks for your feedback. Unfortunately the issue you mention was not resolved in the 5.1 release, and indeed is a different issue to the MAXTRANSFERSIZE issue that Brian mentioned.

    I have forwared this to our developers, and hopefully they will include it in a subsequent release. In the meantime any verification issues will be flagged as warnings, so you should see warning icons on the activity history indicating the problem.

    Hopefully this answers your question... if you have any follow-up questions or issues, feel free to ask.

    Thanks,
    Jason
Sign In or Register to comment.