Registering a Database, Table Problem

Brian DonahueBrian Donahue Posts: 6,590 New member
edited April 14, 2003 9:04AM in SQL Compare Previous Versions
Hello Damien,

Is there a chance that you've got a case-sensitive database, and have
another object with the same name, only in a different case?

-Brian Donahue

"Damien White" <[email protected]> wrote in message
news:[email protected]
> I apologize, I copied the error with another program and the text is
> incorrect. I should have double-checked it. Anyway, here is the actual
> text:
>
> Couldn't register the database. Please check the registration properties.
>
> Error Loading database WEBVIEW2.OpDB
> Error scripting Tables
> Error scripting Table admAllowTransfer
> Automation error
>
> After more investigation, I am able to script some tables from my
dateabase,
> but only a few. I was able to script this database before (about 3 months
> ago) with perhaps an earlier version of the software (I used it as the
> demo).
>
> Any help would be greatly appreciated, I'm very disappointed I can't the
> software to work...
>
> -Damien
> "Damien White" <[email protected]> wrote in message
> news:[email protected]
> > I am trying to register one of my databases over the network. If I try
to
> > script the tables of my database, I get the follow error:
> >
> > SSQL Comparester the database. Please check the registration properties.
> >
> > Error Loading database WEBVIEW2.OpDB
> > Error scripting Tables
> > Error scripting Table admAllowTransfer
> > Automation error
> >
> > I am able to script everything else however (Procedures & Logins). How
do
> I
> > fix the problem?
> >
> > Thank you for your help.
> > -Damien White
> >
> >
>
>

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    What happens if you exec sp_help on this particular table in your database
    that gives you the problem? Do you get more than one entry back?

    -Brian Donahue

    "Damien White" <[email protected]> wrote in message
    news:[email protected]
    > No, I have this same database on another server (as well as my local
    > machine) which I was able to script successfully. The issue seems to be
    > with the particular server... and this particular database as I am other
    to
    > script other DBs off the same server. Unfortunately this is the server
    and
    > this is the particular database which I need to compare against, and the
    > driving reason behind me purchasing your software.
    >
    > For more troubleshooting information, I have also copied the database off
    of
    > this server to my local machine and had no problem scripting it... The
    > issue seems to be specifically with this server.
    >
    > -Damien
    >
    > "Brian Donahue (Red Gate)" <[email protected]> wrote in message
    > news:[email protected]
    > > Hello Damien,
    > >
    > > Is there a chance that you've got a case-sensitive database, and
    have
    > > another object with the same name, only in a different case?
    > >
    > > -Brian Donahue
    > >
    > > "Damien White" <[email protected]> wrote in message
    > > news:[email protected]
    > > > I apologize, I copied the error with another program and the text is
    > > > incorrect. I should have double-checked it. Anyway, here is the
    actual
    > > > text:
    > > >
    > > > Couldn't register the database. Please check the registration
    > properties.
    > > >
    > > > Error Loading database WEBVIEW2.OpDB
    > > > Error scripting Tables
    > > > Error scripting Table admAllowTransfer
    > > > Automation error
    > > >
    > > > After more investigation, I am able to script some tables from my
    > > dateabase,
    > > > but only a few. I was able to script this database before (about 3
    > months
    > > > ago) with perhaps an earlier version of the software (I used it as the
    > > > demo).
    > > >
    > > > Any help would be greatly appreciated, I'm very disappointed I can't
    the
    > > > software to work...
    > > >
    > > > -Damien
    > > > "Damien White" <[email protected]> wrote in message
    > > > news:[email protected]
    > > > > I am trying to register one of my databases over the network. If I
    > try
    > > to
    > > > > script the tables of my database, I get the follow error:
    > > > >
    > > > > SSQL Comparester the database. Please check the registration
    > properties.
    > > > >
    > > > > Error Loading database WEBVIEW2.OpDB
    > > > > Error scripting Tables
    > > > > Error scripting Table admAllowTransfer
    > > > > Automation error
    > > > >
    > > > > I am able to script everything else however (Procedures & Logins).
    > How
    > > do
    > > > I
    > > > > fix the problem?
    > > > >
    > > > > Thank you for your help.
    > > > > -Damien White
    > > > >
    > > > >
    > > >
    > > >
    > >
    > >
    >
    >
This discussion has been closed.