What are the challenges you face when working across database platforms? Take the survey
Options

Missing Dependent Objects

tadewusitadewusi Posts: 4
edited July 23, 2007 10:32AM in SQL Dependency Tracker
I have been using SQL dependency tracker for sometimes now. It looked good initially. I recently discovered that the tool doesn't track all dependencies on a specific object. I'm working on a project that involves daily use of this tool. I have to manually write SQL script to extract/track dependencies across multiple databases.
The weird part of this tool is that it will display the target object as being used by another object, but it will never display the object's dependencies when it is the only object in the project.
:? I updated from schema but to no avail.

Is there something I'm not doing right? May be configuration settling?

Comments

  • Options
    Brian DonahueBrian Donahue Posts: 6,590 Bronze 1
    Hello,

    There is an option in 'Project Options' called 'Add objects that the selected objects use'. This should allow you to choose one object, and Dependency Tracker will pull all of the related objects into the diagram.

    If you have any further questions, please let me know.
  • Options
    I tried just now. It is still not giving its dependencies. Like I said, if you choose one of the known dependencies, the object will appear as a dependent object. :?:
  • Options
    Brian DonahueBrian Donahue Posts: 6,590 Bronze 1
    Is the object type a table? I think that if the table is related to another table by a foreign key, you need to add the table that actually has the foreign key constraint on it first.
  • Options
    It's a function. The problem has corrected itself. I think there is something wrong somewhere. I don't know why this problem should have occured in the first instance. I had to rely on using T-SQL scripts to get the dependent objects.
    Your technical team should please look into this anomaly in the next version.
  • Options
    I am having the same issue.

    I have 3 table functions A, B, and C.
    function A uses funciton B, which in turn uses function C.

    Dependecy Tracker finds the dependency b/t B & C, but not A & B. I have even recompiled all of the functions in the order C, B, A, and that did not work. However, "View Dependencies" in SQL Server does pick up the dependencies.

    Any thoughts?

    Thanks,
    Shane
Sign In or Register to comment.