What are the challenges you face when working across database platforms? Take the survey

Setting Default Availability Options

malcolmtmalcolmt Posts: 9
edited December 12, 2007 12:32AM in SQL Prompt Previous Versions

I will be installing SQL Prompt with SQL Management Studio in a Terminal Server environment.

Is it possible to configure the default availability options?

To be:

SQL Prompt Availability = Off
Candidate List = Manual

i.e. both for new users and when clicking the Restore Defaults button.

Malcolm Tonkin


  • Options
    Brian DonahueBrian Donahue Posts: 6,590 Bronze 1
    Hi Malcom,

    I believe this is possible -- if you set up SQL Prompt the way you like, and copy the %userprofile%\local settings\application Data\red gate\sql prompt 3\EngineOptions.xml and UIOptions.xml to c:\documents and settings\default user\local settings\application data\red gate\sql prompt 3, then whoever logs on to the machine for the first time should get all of the settings files.

    You may also want to bring in TrayApp.ini if you want Prompt enabled or disabled for Query Analyzer.

    I'm assuming all of the default settings are hard-coded, so I don't think those can be set.
  • Options
    Thanks Brian,

    Copying the two xml files worked fine.

    Could not find TrayApp.ini though.

    Malcolm Tonkin
  • Options

    We have just installed version 3.6 on to a new terminal server, but cannot get SQL Prompt to adopt default options of being "turned off", set via the method given by Brian in the previous message on March 28.

    Is this still the correct method to use?

    Each time we launch SS Management Studio, the xml files are immediately created in Documents and Settings\THEUSER\Local Settings\Application Data\Red Gate\SQl Prompt 3, with SQL Prompt set to enabled. This is after having deleted that folder prior to logging on to the terminal server.

    I did find a more recent discussion at
    http://www.red-gate.com/MessageBoard/vi ... ht=default
    which may have some relevence but it is not the same as our problem.



    Malcolm Tonkin
Sign In or Register to comment.