Visual Studio 2500 - Dataset Configuration Wizard error

RoyRoy Posts: 4
edited March 20, 2007 6:12AM in SQL Packager Previous Versions
Hello,

I used Packager to create a package that updates a customer database. I created a backup of the client database in SQL express and restored the client database with a rename. So that I can use it as the develop database. This all works fine and the application created in VS2005 also works fine.

However today I wanted to add a new table to the dataset in VS2005. I start the dataset configuration wizard and all my tables appear twice in the list of tables. Once with the original name and once with the prefix dbo. For example: Customer and dbo.Customer.

The tables with the dbo. prefix are marked with a Red Cross in the checkbox. Hovering over them display the error message: "Element .. in the dataset references an object missing from the database. "

The tables without the dbo. prefix are not marked. When I mark these tables VS2005 indicates that the table will be renamed to Customer1.

The same issue applies to all the views in the database.

Is there a way to solve this problem without having to recreate the entire dataset?

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hi Roy,

    I'm not sure exactly what the problem is -- the Visual Studio dataset information muddies the issue up a bit.

    Is the problem that the tables are being created with different owners? This would be the only way you could have two objects in a database with the same name. Truthfully, the other way would be to have a case-sensitive database and have two object names, differing in case.

    But you can end up with objects having different ownership if they were originally created with no owner, and inherited implicit ownership from SQL Server. If this is the case, when the table is recreated, the ownership will once again be inherited from whatever user you had connected to the database as. I think that this could be the problem.
  • Hello,

    I think that this was the problem. When I tried to open the database diagram I got a message saying that the database had no owner. After I assigned the SA account as owner, this worked again. I couldn't get the problem solved in VS2005 so I recreated the dataset....

    Roy
  • The only way I could solve this problem was to delete the dataconnection in het server explorer, then delete the dataset, remove the connectionstring. Then set up new dataconnection, connectionstring and dataset. I think the problem is within the dataconnection somewhere, but still have no idea where exactly.
Sign In or Register to comment.