Problem - restore step is failing for one out of four dbs...

randyvrandyv Posts: 166
edited March 5, 2007 1:49PM in SQL Backup Previous Versions
I just set this up Friday, and it appeared that everything was fine, but I checked the failures log this morning and 1 out of 4 databases failed every restore attempt on the standby server. What follows is the error that keeps repeating for every restore attempt.

What I'm confused about is why this is only happening to one out of four databases. They were set up identically, so I would expect all four to fail or all four to succeed on such mundane things as logins.

The other thing that has me baffled is I have email set up to send status of EVERY job. I only had SUCCESS messages all weekend.

Anyone know what is going on?
TiA
randyv

ERROR ==========================================
Date 3/5/2007 9:20:00 AM
Log Job History (Log shipping: restore [Whaley])

Step ID 1
Server WHALEY03
Job Name Log shipping: restore [Whaley]
Step Name Step 1
Duration 00:00:00
Sql Severity 16
Sql Message ID 50000
Operator Emailed
Operator Net sent
Operator Paged
Retries Attempted 0

Message
Executed as user: WHALEY03\SQLBackup. SQL Backup job failed with exitcode: 220 SQL error code: 0 [SQLSTATE 42000] (Error 50000). The step failed.
What we do in life echoes in eternity <><
Randy Volters

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    It looks like a fairly harmless warning message (as opposed to an error message). It indicates that there were no log backups to restore. Maybe staggering the restore job in such a way that there will always be a log backup waiting would make the warning message stop.
Sign In or Register to comment.