Profiler doesn't work with web service in SSL

I have a web service which runs over SSL in IIS6.0 environment. However when i try to use ANTS profiler for memory profiling the web service, it doesn't load the web service in IE with "server error". And when i close the IE, i get this message:

ANTS Profiler
The web application PacketDistribution/packetdistribution.asmx has not loaded the .NET Framework. Please check that PacketDistribution/packetdistribution.asmx is an ASP.NET web application. Please note that accessing cached web pages will not load the .NET Framework.

ANTS Profiler


Doesn't the software support SSL ? I can't remove the SSL since the web service requires certificates.

I am looking forward to immidiate resolution since this would determine whether we would buy the product.

Also a phone contact would be helpful too.

Thanks
Vik

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hi Vikas,

    I'm sorry I didn't get around to returning your call. I had taken a bit of time off. You probably would be better served to leave a message at the main support number.

    That aside, I have seen this issue happen in testing, and as far as I know, the cause was never discovered. I don't think you can use webdev.webserver with SSL as a workaround.

    Is your IIS hosting multiple websites, and is a cert bound to all of them? I have a feeling that because your app is running in a different app pool (called RedGateTestAppPool), your web application may be running on the default website (W3SVC/1).
  • Hi Brian,
    Thanks for your message. We don't have an option to use any other web server than IIS.

    Yes our IIS is hosting multiple web services and all of them are on SSL with this particular web service requiring a client certificate.

    These web services are running under a special apppool.

    How does RedGateTestAppTool get created since i don't see it ?

    In summary, do you think there is any way i can use the profiler to profile my web service under the above environment ?

    Thanks
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hi Vikas,

    I think it will work if your IIS is configured for IIS 5 isolation mode. We are giving that a try here as I type so there should be a reply later today from either Robert or myself as to whether it works or not.
  • Hi,

    When profiling an IIS6 based web application, we start a new worker process, running the RedGateTestAppTool - this doesn't get written to the metabase, so it won't show up in the IIS manager application, and only lasts for the duration of the profiling session.

    As Brian mentioned, if you run IIS6 in IIS5 isolation mode, you should be able to profile an HTTPS based site, but of course this does remove your ability to run sites in different application pools, so if you're doing this on a production server (not really recommended anyway), that could be an issue.

    Looking ahead, ANTS Profiler 3 supports SSL on IIS7 (under Vista or Longhorn), if that's of use to you.

    Hope that helps,
    Robert
    Robert Chipperfield
    Red Gate
  • Hi again,

    Just to add a little explanation to that one, the reason we can't profile SSL site in IIS6 running in worker process isolation mode is that the SSL encryption / decryption is handled by the Lsass.exe service, delegated by the HTTP.sys kernel module. This means that it isn't possible to start a standalone worker process and service HTTPS requests, unfortunately.

    In IIS5 isolation mode, we profile the inetinfo.exe service rather than the worker process, at which point the HTTP protocol stack is unaffected by our profiling (also, SSL is handled in-process within inetinfo.exe rather than by lsass.exe).

    Hope that helps,
    Robert
    Robert Chipperfield
    Red Gate
Sign In or Register to comment.