Startupdelay in SQL Server Management Studio

bbrbbr Posts: 3
edited February 14, 2007 4:10PM in SQL Prompt Previous Versions
I often work with databases from our customers which I connect through on-demand VPN connections. In this case I don't have a connection to my local network in parallel because of security issues. Otherwise when I work local I don't have a connection to the customers database. When I start the SQL Server Management Studio there is a long delay (perhaps SQL connection timouts). When I delete all the cached schema information fron the SQL prompt cache management the startup delay is no longer present until I have newly connected to the remote database.

Any help or workarounds for this issue are welcome.

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hi,
    I don't see Prompt doing anything until you connect to the SQL Server. Does going into Cache Management and setting 'automatically update' to off help any?
  • This problem occours only when you have registered a remote database earlier (for example yesterday). Now if you want to start the server managment studio to connect a previous registered database in the local network there is the startup delay. I think that SQL Prompt will try to refresh also the remote database (even if it is not needed, because we do not connect to these databases). The auto refresh checkbox is deselected.

    Kind regards
  • Bart ReadBart Read Posts: 997 Silver 1
    I think that Prompt must be trying to connect to the remote DB somehow. Somebody's also reported this problem with Query Analyzer, also connecting to DBs over a VPN. I'm going to have to take a look into it as part of the package of improvements for 3.1 so it *will* be fixed.
    Thanks,
    Bart
    Bart Read
    Principal Consultant
    bartread.com Ltd
Sign In or Register to comment.