What are the challenges you face when working across database platforms? Take the survey
Options

No results using ANTS Prof 1.30

Brian DonahueBrian Donahue Posts: 6,590 Bronze 1
Hi Ian,

Have you got a .pdb file in the bin folder along with the compiled dll
assembly in the website?

Regards,

Brian Donahue
Red Gate Technical Support

"Ian Cox" <ian_cox2000@hotmail.com> wrote in message
news:GyGbVxNkEHA.3104@server53...
> Hello.
> I have just installed ANTS Profiler 1.30 and am unable toget any results
for
> asp.net applications. I have tried aspnet_regiis -i as suggested in
another
> post with no success. I am using VS.NET 2002 and XP professional.
>
> Any ideas?
>
> Cheers
> Ian
>
>

Comments

  • Options
    Brian DonahueBrian Donahue Posts: 6,590 Bronze 1
    Hi,
    is there a way to tell ants to hook the iis process and let me pick a thread?

    Profiler should profile all of the code being run by the inetinfo process, so it's not a case of finding the right thread because Profiler should be profiling everything that's running in IIS that is .net managed code. All processes launched by inetinfo should inherit our Profiler environment.

    Would it be too much to ask to try changing the application protection level in the IIS virtual directory to Low (IIS Process) and then profile and see if results come back then? Maybe your inetinfo process is not passing its' environment to the processes that it launches.
  • Options
    Brian DonahueBrian Donahue Posts: 6,590 Bronze 1
    Is the website running on port 80? ANTS Profiler requires that.

    Other than that, the results are sent across a pipe using port 8087. There is nothing else using that port, is there?
  • Options
    How about this idea:

    Does the ASP .net web application do any page output caching? If you were retrieving pages that hadn't changed, then ASP .net would serve you with a cached copy of the page and the ASP code would not run.

    You can enable/disable output caching by putting a directive on your .aspx page such as:

    <%@ OutputCache Duration="120" VaryByParam="none" %>

    If you remove this directive, the caching should be disabled.
  • Options
    Brian DonahueBrian Donahue Posts: 6,590 Bronze 1
    Hi,

    Usually if you change the IIS configuration for any reason, doing an IISRESET.exe from the command line will enforce these changes. But a reboot works pretty well too!
Sign In or Register to comment.