What are the challenges you face when working across database platforms? Take the survey
Options

Newbie Help

Pablo_In_NZPablo_In_NZ Posts: 8
edited February 7, 2007 6:05AM in SQL Prompt Previous Versions
I have just downloaded the demo, and it fell at the first hurdle, which is very frustrating. I'm assuming I am missing some setting or something.
It all installed OK, but when I start up SQL Query Analyser, SQL Prompt sits there for a while, and I get the little box bottom right 'Load metadata'
then i get a message box saying'Could not retrieve the database schema. The database may no longer be present or a network connection could not be established."
The SQL server is local on my laptop, and I get this message for all databases. I tried setting Connection Credentials using the actual server name and also (local), but still get the same message. I am using SQL Server Authentication.
The SQL Server version is 2000 - 8.00.534 (Intel X86)
What am i doing wrong here ??!! :?

Comments

  • Options
    Bart ReadBart Read Posts: 997 Silver 1
    Hi Pablo,


    Sorry to see you're having problems. When you log in to SQL Server do you have dbo access to the database?


    Thanks,
    Bart
    Bart Read
    Principal Consultant
    bartread.com Ltd
  • Options
    Yes. I am logging in as 'sa' which is the owner of the database. I've been really busy this week , so have not had time to investigate further. I am going to trying setting up a database with Windows authentication and see if I can get in to that.
  • Options
    OK, had a little time and created a database uing windows authentication and my user profile (which is an administrator) on my laptop. I changed the connections setting to use windows authentication for the (local) server and the database I had just created. Still get the same message as before.

    I have re-installed SQL Prompt 2.0.0.59 and that has no problem retrieving the metadata for all databases.......
  • Options
    I had similar problems to the ones that you are describing when I had a badly setup server alias on my machine. Have you setup any server aliases on your machine and are they all pointing to the correct places.

    Lionel
    Software Engineer
    Red Gate Software
  • Options
    Nope, not set up any server aliases that I am aware of ( I don't know how to for a start !)
    I do have SQL Express 2005 on my laptop as well as SQL Server 2000. Stopping the SQL Express had no affect.
    What's changed from SQL Prompt 2 for connections (or is it completely different) ? As I mentioned, Version 2 has no problems connecting.
  • Options
    Helllooo ! Anyone there ?? Anyone got any other suggestions ? I'm fast running out of my 14 day trial period, and since I can't even get it to connect, it's highly unlikely I'm going to splash the cash to purchase it !
  • Options
    Sorry for the late reply. I am really low on ideas. I don't think we are doing anything very unusual in our connections. My only sugestion is to create an alias for that server and try and connect to that alias in SSMS and QA (A bit of long shot I know but might make sure that prompt is using the right connection properties).

    Lionel
    Software Engineer
    Red Gate Software
  • Options
    OK, cheers no worries., I'll have a look.It's a bit strange that version 2 has absolutely no problems connecting though
  • Options
    Well we are still using a standard .net connection so the only thing I can think of is that the differences arise because we are using .net 2.0 rather than 1.1.

    Lionel
    Software Engineer
    Red Gate Software
  • Options
    Finally found out what it was.
    It was an alias problem as you suspected - cheers for that.
    For some reason (possibly due to SQL Express 2005 on the machine as well ?) new aliases don't apear to work.
    When I changed the default server to be used in the options tab to 127.0.0.1 (rather than the actual server name or (local)) it worked.
    Am having a few issues with the way it works, but at least it's working now :)
  • Options
    Thanks for getting to the bottom of the problem. I guees .net 2 must have changed the way that it handles aliases as a few people seem to be having problems with aliases. If you want to post your aditional problems in a new thread we are always interested in the feedback. Thanks.

    Lionel
    Software Engineer
    Red Gate Software
Sign In or Register to comment.