404 on 2003

Brian DonahueBrian Donahue Posts: 6,590 New member
Hi Steven,

I can't manage to reproduce this here, but I'd imagine it has something
to do with the fact that ANTS Profiler logs on as a batch to start Internet
Explorer. Have you tried going into Add/Remove programs and turning off the
Internet Explorer Enhanced Security configuration?

Please let us know if that works!

Regards,

Brian Donahue
Red Gate Technical Support


"steven bristol" <[email protected]> wrote in message
news:pJRkm%[email protected]
> I just installed the trial, and I am trying to test a web site on
localhost.
>
> I followed the instructions in the help, but when the web page opens it
just
> says 404 NOT FOUND.
>
> I double checked the url by copying it from the browser launched by ants
to
> a new one. It worked. I also tried to leave the url blank, and select from
> the list that is displayed when the browser launches. 404.
>
>
> Can someone help me?
>
> Thanks,
> steve
>
>

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hello,

    Which version of Profiler does this occur on? In versions 1.x, a weird thing happens with IIS6 in that the web browser will go out and get www.example.com instead of the website that you had chosen to profile. We'd verified this by running Windows Network Monitor against a profiling session as you can't see www.example.com appearing in the address bar of Internet Explorer. This had been fixed in 2.0, although we don't know the reason why it started working and the fix was not intentional.

    If you're on Profiler version 1.x, the only thing I can suggest is to upgrade to 2.0. Unfortunately it is not a free upgrade.
  • Does anyone have a solution for this as I have exactly the same problem? Registered v2.0 does not work (404) v1.3 works fine!!

    Vince
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hi Vince,

    Is it possible for you to try to access the web application from another machine? Maybe a proxy setting or something similar is interfering with ANTS Profiler on your local machine. As far as ANTS Profiler is concerned, it doesn't matter which machines the requests are comping from as long as the code in the web application is being run.
  • Brian,

    When I get a chance I will, I needed to do some profiling and have had to revert to 1.3 for now.

    Vince
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    You may want to consider upgrading to version 2.5 of ANTS Profiler if you're using a 2.x version already. There is a fix for a problem in 2.5 that handles a bug where your web browser would attempt to open http://www.example.com when profiling web applications on a Windows 2003 Server.
This discussion has been closed.