Competition: What’s your favorite Redgate tool? Enter now.

Creating db too slow

ramil.dramil.d Posts: 2
edited December 21, 2006 3:31PM in SQL Packager Previous Versions
Hello,

Is it normal that after packaging/scripting my database (300+MB) using SQL Packager 5 and running the generated .EXE file it takes almost 1 hour to finish the database creation from scratch? I noticed that the script of the schema takes about less than a minute but when it comes time to run the script of the data to populate the database created it takes an hour? Is there any settings that I need to setup in order to optimize the .EXE to perform the database creation?

If it helps I removed the Transaction Option and enabled the compression of the .Resx files generated by the C#.NET project.

Thanks in advance.

Comments

  • Eddie DEddie D Posts: 1,688 Rose Gold 5
    Hi Ramil

    Thank you for your post into the SQL Packager forum.

    If you edit the SQL Packager options and select the data tab.

    Please try selecting the following options:

    Drop primary keys, indexes and unique constraints - Drops then recreates primary keys, indexes, and unique constraints in the synchronization SQL script. If the primary key, index, or unique constraint is the comparison key, it cannot be dropped.

    Disable DML triggers - Disables then re-enables DML triggers on tables and views in the synchronization SQL script.

    Disable DDL triggers - Disables then re-enables DDL triggers on tables and views in the synchronization SQL script.

    Hopefully enabling the following options will allow your data update run quicker.

    Best Regards
    Eddie Davis
    Red Gate Software
    Technical Support
    Eddie Davis
    Product Support Engineer
    Redgate Software Ltd
    Email: [email protected]
Sign In or Register to comment.