Error while reading constraints

jesse.taberjesse.taber Posts: 3
edited November 29, 2006 7:59AM in SQL Compare Previous Versions
I received the following error message while the application was reading the constraints in the database on the right hand side of my comparison:

"Specified cast is not valid."

The account being used to connect to the database causing the issue is limited to read only access.

I tried performing a similar comparison between two other database both living on the same two machines as the comparison with the issue and had no problems.

Any suggestions would be appreciated.

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hi Jesse,

    You'd hinted at the permissions of the user, I think this could be the problem. On SQL Server 2005, you can set viewing permissions on schemas and other objects. This can prevent SQL Compare from getting some vital schema information from the database, resulting in NULL data being returned, preventing the software from being able to compare two SQL objects.

    Does the same database comparison work using a sysadmin login? If so, access restrictions could be the porblem.
  • Yes, using the sysadmin login worked correctly. We'll have to check in to the schema viewing permissions.

    Thank you.
Sign In or Register to comment.