Competition: What’s your favorite Redgate tool? Enter now.

Using path fails

rbennet8rbennet8 Posts: 74
edited August 23, 2006 7:29AM in SQL Packager Previous Versions
I can not provide a path to the executable created by Packager version 5.2. I have tried this in a dos command and it just returns the dos prompt. If I cd to the location of the executable, the it executes.

I have an executable created as an C# project called mySQL.exe. I move this to c:\source\mytest.

If I open a dos command and cd to c:\source\mytest, I can execute mySQL.exe with no problem.

If I cd c:\ and try to execute using c:\source\mytest\mysql.exe, I return to the dos prompt.

This worked in Version 4.0. What can I change to make this work in version 5.2

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hi Bob,

    I think this relates to the 'can't rename package' problem we'd introduced in v5.2. The packages try to get a hold on their own internal resources using the executable's name, which is invalid if changed or referenced from another directory. I'll send you a replacement SQL packager code template that you can use to generate a package that should work.

    And I only say *should* because the fix was not designed especially for this specific problem.
Sign In or Register to comment.