Unable to build an object free of serial number prompt

archavez00archavez00 Posts: 2
edited August 15, 2006 1:25PM in SQL Toolkit Previous Versions
Hi,

I’ve a licensed copy of your SQL Toolkit V. 5.1. I’ve been experiencing some problems with the license in the compiled distribution objects. Every time I try to start the application on a machine different than the development one it shows a dialog that says:

This is a 14 day trial. To use a copy of SQL Toolkit after the trial expires, you need to buy…. (the complete message is on the image I’ve attached to this mail)

When I run it on the development environment I’ve no problem.

We bought our license form Component Source (http://www.componentsource.com)

We are using Visual Studio 2005 with SQL Express 2005 for the application. Our environment – for both development and production – is Windows XP SP 2.0

I’ve tried the solution given in the KB article

http://www.red-gate.com/messageboard/viewtopic.php?t=491

but it still gives me the same problem

Can you tell me which would be the proper steps to compile the application so it won’t ask for the serial number anymore? Or could it be a license problem?

This application is a crucial part of a large project, so it’s critical for us to be able to fix this as soon as possible.

thx.

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hello Armando,

    The problem is this: when you build a Toolkit project successfully, the licensing information should be embedded into the assembly resources. If it isn’t, then Toolkit applications behave as you describe. On your development machine, they detect and use a SQL Toolkit licence that’s available on the local hard disk, which explains why the application should work on the development machine and nowhere else.

    What you should check first is the licenses.licx file in the project. The presence of this file in the format mentioned in the help file is what invokes the licensing client that allows you to enter your serial number to create a licnece for the application. If this is not happening, either the licensing has already been done (there is a Serial Number key in the registry and a SQL Toolkit.lic file in the assembly references path for the application) or the licenses.licx file is not correct.

    Here are the requirements for licenses.licx:
    • The file is linked to the Visual Studio project, it appears in the list of files in the solution explorer
    • The file has one of the referenced assembly objects as the content, ie RedGate.SQLCompare.Engine.Database (note this is case-sensitive!)
    • Check the file’s properties to make sure it is type ‘Embedded Resource’
    • If you have changed licenses.licx in any way, I’d recommend a project rebuild (instead of just a build)

    Please let me know what you find!
Sign In or Register to comment.