What are the challenges you face when working across database platforms? Take the survey
Options

Cannot install on an Itanium

Andy DaviesAndy Davies Posts: 5
edited August 9, 2006 6:24AM in SQL Backup Previous Versions
Installation on our Itanium was unsuccessful (after testing on an x64 successfully).

During installation I deselected "install XP on default instance" (since default is PROD and TEST is the instance I wanted it on).
Went through OK until the end, then the installer displayed "The Update Service does not recognize this product. Please contact your software vendor for updates to this product. Error 13004: Version Not Registered with the Agent".
I clicked Finish anyway.

The GUI worked and I registered the test instance successfully.
Then tried to install the extended s/procs (from the main menu - Tools) and it failed to register the x/procs (despite having super admin rights) and told me to manually register them.
Manually registered all s/procs successfully.
Try to connect to the server but get message:
"Cannot load the DLL xp_sqlbackup.dll, or one of the DLLs it references. Reason: 126(The specified module could not be found.)."

Checked Windows services - "SQL Backup Agent" is not there!

Tried repairing - keep getting "does not recognize" error each time.
Tried modying - same.
tried uninstalling - get error "Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor".

PS. This is a production box so at the very least I need to remove this!
But, preferably, I'd like to get it to work...[/img]

Comments

  • Options
    peteypetey Posts: 2,358 New member
    Let's work on getting at least the server components to install. I assume you're already removed all traces of SQL Backup from your Itanium server.

    - Copy SQBServerSetup.exe from your x64 server to your IA64 server.

    - Run SQBServerSetup, install to the required instance.

    - Try running the 'sqlbackup' extended stored procedure from Query Analyzer/SSMS.
    It it reports "Cannot load the DLL xp_sqlbackup.dll, or one of the DLLs it references. Reason: 126(The specified module could not be found.).", pls check in the SQL Backup installation folder, if an IA64 sub-folder was created, and if xp_sqlbackup is contained in there, and that the same xp_sqlbackup.dll is found in the SQL Server instance's Binn folder.

    Thanks.
    Peter Yeoh
    SQL Backup Consultant Developer
    Associate, Yohz Software
    Beyond compression - SQL Backup goodies under the hood, updated for version 8
  • Options
    I had deleted the "Red Gate" folder from "Program Files (x86)" and copied the setup file locally.
    But when I run the setup file it only allows me to modify, repair or remove.

    Modify fails with aforementioned error (Version Not Registered) and installs the following files (to C:\Program Files (x83)\Red Gate\SQL Backup\):
    * ProductActivation.exe
    * sqb2mtf.exe
    * SQBServerSetup.exe
    * SQLBackup.chm
    * SQLBackup.exe
    It does not appear to install the XP DLL's (in C:\Program Files\Microsoft SQL Server\MSSQL\Binn\ or the x86 location for either instance).

    Repair does the same as modify.

    Remove fails with aforementioned error "problem with this Windows Installer package" (whether I've deleted the Red Gate folder or not).
  • Options
    peteypetey Posts: 2,358 New member
    Pls try installing just the server components using SQBServerSetup.exe, not the regular installer.
    Peter Yeoh
    SQL Backup Consultant Developer
    Associate, Yohz Software
    Beyond compression - SQL Backup goodies under the hood, updated for version 8
  • Options
    Whoops - missed that (sorry)!

    Copied over the x64 file...it appeared to be identical to the existing one there (from the failed i64 install) in size & modified datetime but I overwrote anyway.
    It ran mostway through but failed with:
    "Internal Error: Expression error 'Runtime Error (at 31:469): Internal Error: Cannot access 64-bit registry keys on this version of Windows."

    However it's created a sub-folder in "Red Gate", installed various files, installed the service and the backup / restore appears to be working.

    It didn't auto-start the service but when I manually started it it started fine.

    So, in short, now working, but VERY messy...and don't know what it missed in the registry?
  • Options
    peteypetey Posts: 2,358 New member
    Which version of Windows are you running on this Itanium box? Thanks.
    Peter Yeoh
    SQL Backup Consultant Developer
    Associate, Yohz Software
    Beyond compression - SQL Backup goodies under the hood, updated for version 8
  • Options
    Windows Server 2003 Ent Ed.
    Hardware is an Itanium 2 1.5GHz with 8GB RAM.
    2 instances - default is production with 5GB RAM and TEST with 3GB.
    Running MSSQL as domain user service account (which is a DBAdmin within MSSQL).
  • Options
    peteypetey Posts: 2,358 New member
    It appears that part of the setup does not recognise your operating system as part of the Win64 family.

    Would you be willing to run a small test app to help us trace the problem? Thanks.
    Peter Yeoh
    SQL Backup Consultant Developer
    Associate, Yohz Software
    Beyond compression - SQL Backup goodies under the hood, updated for version 8
  • Options
    peteypetey Posts: 2,358 New member
    Turned out that the problem was because the SQL Backup installer requires 64-bit Windows 2003 to have Service Pack 1 installed, otherwise it's not able to read the 64-bit registry keys.
    Peter Yeoh
    SQL Backup Consultant Developer
    Associate, Yohz Software
    Beyond compression - SQL Backup goodies under the hood, updated for version 8
Sign In or Register to comment.