Error: The web application has not load the .Net Framework

bob666zbob666z Posts: 3
Hi,

I get the following error when I tried to use it with one of our ASP.Net
applications:
===
The web application products/vendorlogin.aspx has not loaded the
.Net Framework. Please check that products/vendorlogin.aspx is a
ASP.Net web application. Please note that accessing cached web
pages will not load the .Net Framework.
===

The error happens in the following scenarios:
1) make the web app as the default web site in IIS, i.e.
http://localhost/default.aspx
2) use a port number for the web site, i.e.
http://localhost:92/default.aspx
3) change ASP.Net setting in IIS to point to version 2.0

In all above scenarios, the URL were selected from the dropdown
list in ANTS Profiler.

ANTS Profiler worked well with this application before we installed the
.Net Framework 2.0.

Machine configuration:
1) has Windows 2000 Standard Server with Service Pack 4.
2) has both .Net Framework 1.1 (1_1_4322)and 2.0 (2_0_50727)
3) has ANTS Profiler 2.6 on same machine
4) has SQL Server 2000 Standard
5) Web server is IIS 5

Targeted web application is a ASP.Net 1.1 application
(I checked its ASP.Net in both IIS and web.config file).
It has some 3rd party DLL references.

Would you please give me some help?

Thank you

Bob

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hi Bob,

    The simplest thing to check is that you're compiling in debug mode. Because Framework 2.0 always dynamically compiles web applications now, you should check that DEBUG=True is specified in the application's web.config file.

    You can also use the new ASP .NEt config editor in IIS. (Virtual Directory->Properties->ASP .Net tab, Edit Configuration button, Application tab, Enable Debugging)
  • Hi, Brian,

    As I mentioned in my original post, the web application used in
    ANTS Profiler is a ASP.Net 1.1 application not a 2.0 application.

    Plus, debug=true in web.config, and the "Edit Configuration"
    button is disabled in IIS(Is the because IIS is set to ASP.Net 1.1.4322
    on this web site?)

    Additionally, I tried to use ANTS Profiler with a ASP.Net 2.0 web
    application, I got similar error.

    I also tried the 3rd method(run RegSvr32 RedGate.Profiler.Core2.dll)
    mentioned in the article:
    http://www.red-gate.com/MessageBoard/vi ... php?t=1071

    It was successful, but the same error still happens.

    The ANTS Profiler did work fine with this web application and
    other ASP.Net 1.x applications.

    After I installed .Net Framework 2.0 and upgraded ANTS Profiler
    to version 2.6, it stops working with any ASP.Net applications.
    Evn though it still works with .Net desktop applications, to profile
    the ASP.Net web applications was the main reason why we bought
    ANTS Profiler. Now it becomes useless.

    It seems like ANTS Profiler 2.6 has some issues either with ASP.Net 2.0
    web applications or with the environment where both ASP.Net 1.1
    and ASP.Net 2.0 exist.

    Any ideas?

    Thank you

    Bob
  • Hi there,

    I'm sorry that you are having trouble with ANTS Profiler. Could you try out the following for me please?

    Enable logging by creating a folder Logs where ANTS Profiler is installed

    Stop the ANTs Profiler Service

    Try to profile your .NET 1.1 web site

    Send the servicelog.txt though to [email protected]

    Many thanks,

    Tom Harris

    Red Gate Software
  • We now have an alpha release of ANTS Profiler 2.7 that we hope fixes this problem. We are mailing you with details.

    Thanks,

    Tom Harris
  • I have the same scenario where I am trying to profile my ASP.NET 1.1 solution installed on a development machine that is also used to develop .NET 2.0 programs.

    I created a Logs directory in the C:\Program Files\Red Gate\ANTS Profiler directory and only generated a UILog.txt file. What can I do to make sure I get enough information to send to tech support on this issue? Can I request a copy of the 2.7 alpha?

    -Jesse
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hi Jesse,

    You'll probably want to try restarting the ANTS Profiler Service if you don't get a copy of corelog.txt in the logging folder.

    If there still isn't a corelog.txt, then the profiler's core component isn't loading, which could be the root cause of the problem.

    A quick way to figure out if the component is being loaded is to look at the lower-left on the Profiler's main window when you start profiling. If it continually says 'waiting for connection', then something may be preventing core from instrumenting your code.
  • Hi there,

    I have just downloaded trial version of ANTS profiler 2.0 for testing my application and to know how Ants profiles works and is how effective.

    I have a web application built using ASP.NET and VS2005.
    I am trying to profile for memory usage, but whenever i try to take snapshot of my web pages functioning it says .Net framework not loaded for this page.
    but if i give default.aspx it works and shows me some summary. can you suggest if i am doing anything wrong.
    One more thing i wanted to ask is it possible to record all activities for all pages instead of profiling for each page if yes pls tell me how.

    i have checked all suggestion as you have told to "bob666z" for debug and configuration in above posts. pls reply soon.

    thanks
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    edited August 18, 2006 1:00PM
    Hello,

    Performance or memory profiling, and are you using the profile all methods or the profile only methods with source code?

    Thanks.
  • Hi Brian,

    i am using for Memory profiling not performance profiling. today i am trying to check for performance profile.

    and one more thing, i have both version of .net framework (1.0 & 2.0) and VS (2003 & 2005) on my machine. is that a problem.
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Thanks.

    Is the lower-left bar saying 'waiting for connection'? This means that the UI and the back-end component aren't communicating.
  • Hello,

    I have downloaded eval. version of ANTS profiler 2.7, and having
    "The web application ... has not loaded the .Net Framework" problem.

    I have both framework 1.1 and 2.0 installed, application which I try
    to profile for performance runs under 2.0 framework.

    I have created Logs folder, these are lines from one of logs (I suspect that profiler fails to properly determine framework version,and waiting for application to use 1.1):
    Parse IIS metabase
    Checking the framework version
    Unable to determine framework version; using default
    Computing the default framework version; metabase path = [url=IIS://localhost/w3svc/1]IIS://localhost/w3svc/1[/url]
    DefaultFrameworkVersion determined from script map for [url=IIS://localhost/w3svc/1]IIS://localhost/w3svc/1[/url]
    DefaultFrameworkDirectory determined from script map for [url=IIS://localhost/w3svc/1]IIS://localhost/w3svc/1[/url]

    Thanks.
  • Hi there,

    we will be releasing a patch to ANTS Profiler 2.7 next week to fix this problem. The patch will allow you to specify the version of .NET that you're web application should be using.

    Regards,

    Tom Harris

    Red Gate Software
  • Hello.

    Any progress with the patch?

    Thanks, Alexander.
  • Hi there,

    we released the update yesterday. You can download it using file 'Help' -> 'Check for updates...'

    Regards,

    Tom

    Red Gate Software
  • Even after the update I am still getting this error message. I am running profiler on a .net web app on Windows Server 2003. Has anyone else run into this issue and found a resolution?
  • Hi

    I have been trying to profile an application which previously worked in the profiler. I was recently given a 64 bit machine - I am not running XP64 i am running the 32bit operatiing system.

    DEBUG=true is set in the web config file.

    Each solution for each assembly has been built in debug mode.

    I have upgraded profiler from 2.6 to 2.7.1.20

    I select .Net Framework 1.1 when creating a project and when i try to take a snapshot i get the 'web application ... has not loaded .Net framwork' error.

    Can you please suggest what i might be doing wrong here - its driving me insane.

    Cheers

    Nick
  • I am having the same issue before and after upgrading to the 2.7.1.20 version. Could someone from red-gate please provide and update on this bug? If you need me to provide application/pc spec details let me know.

    Joe
  • Hi Joe,

    I'd just like to confirm one thing with you, if possible. Assuming you're running IIS6 in normal mode (rather than IIS5 Isolation Mode), when you start profiling it should pop up a copy of Internet Explorer directed at the site you are profiling.

    You might have noticed that this is actually on a different port - I think 8013 by default. Could you confirm that when browsing through your web application, you remain on that port, rather than somehow reverting back to port 80?

    Many thanks,
    Rob
    Robert Chipperfield
    Red Gate
  • Rob:

    I am actually running my application in IIS 5 Isolation Mode. Under my default web site I have a virtual directory set up as an application running in medium pooled protection.

    Just for reference my setup is as follows:
    Windows XP
    .Net 1.1 and 2.0 framework installed
    Visual Studio 2005
    IIS 6 (All virtual directories setup to run as applications)

    Let me know if you need me to look at anything else. Glad to help,
    Joe
  • Hi,

    Just to clarify, if you're running IIS6 on WinXP, does this mean you're running WinXP 64bit edition? (I don't think IIS6 is available for XP 32bit)

    If so, I'm afraid we don't support applications running in 64-bit mode at the moment - this is on the cards for the next release of ANTS.

    If you're trying to profile a normal desktop application on a 64-bit machine, it is possible to target it for a 32-bit processor, at which point even if you run it on a 64-bit OS, you will be able to profile it. However, it doesn't appear to be possible to set this CPU target for web applications.

    Rob
    Robert Chipperfield
    Red Gate
  • Sorry to clarify I am running IIS 5 in isolation mode, Windows XP 32 bit. I am only trying to profile a .net web application and HAVE had success profiling a windows application on the same machine.
  • OK, no problem. I think in this case you seem to be having a very similar problem to the one being discussed on this thread. It might be worth keeping an eye on that one, and possibly even having a look using Process Explorer if you have the time.

    Have you ever managed to successfully profile an ASP.NET application, or has it just stopped working with recent updates or changes?

    Rob
    Robert Chipperfield
    Red Gate
  • Unfortunately, I have not had a successful profile attempt on this machine. It's only a year old and I put VS 2005 and the 2.0 framework on it immediately and then purchased the profiler around the end of October.

    I will download the process explorer as you suggested and post my results to the thread you suggested.
Sign In or Register to comment.