Backup failure, not enough disk space

jkweberjkweber Posts: 3
edited June 19, 2006 12:30PM in SQL Backup Previous Versions
I've noticed some prior issues with this in both 3.x and 4.x discussion groups, it has been suggested that it is a failure to write something greater than 1mb to a UNC path. A Red-Gate developer even posted a tool to test this theory. However, there really has been no specific response as to what the fix is, or at least I haven't found it yet. So my question is, I have a SQL job that uses the extended SP that works 99% of the time but every now an then it fails due to Error 112 (Not enough space on disk). The backup path is UNC and the file server drive that this UNC path points to has .3tb available at any given time which is more than enough to handle the 1gb of SQL backups. When the error occurs, we change the target location to a local drive and the command completes successfully. The version of SQLBACKUP is 3.x running on a SQL Version 2000 sp3a (8.00.760 ). The SQLBACKUP command in the SQL Job looks like

'-SQL "BACKUP DATABASE TO DISK = WITH COMPRESSION = 2, ' + ' LOGTO = , ' + 'password = [xxxxxxxxx], ' + 'init"'

Thank you

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hello,

    The SQL error 112 issue had to do with the buffers used to to hold backup data when backing up to a network share.

    This was fixed in version 4.x by adding the MAXDATABLOCK backup parameter, which allowed you to manually configure the buffer size.

    I don't think that there is a solution for 3.x. I can say that there were some updates for the 3.2 release. If you don't have the xp_sqlbackup.dll version 3.2.0.5 and the SQL Backup program version 3.2.0.10, then maybe you can try downloading these from ouf FTP site (ftp://ftp.red-gate.com) and apply them to your installation.

    Hope this helps!
  • Brian,

    Thanks for the info. I checked server in question and the file version for the dll is 3.2.0.1 and the exe is 3.2.0.1. I will download the suggested files and see if that makes a difference.
Sign In or Register to comment.