What are the challenges you face when working across database platforms? Take the survey
Options

File or assembly name vjslib not found

Dan J ArcherDan J Archer Posts: 89
edited February 18, 2016 5:22AM in SQL Dependency Tracker
Hi all,

If Dependency Tracker reports this, it generally indicates that the Visual J# Runtime is not present. This is a required component for Dependency Tracker to run. The absence of the Visual J# Runtime could be attributable to a an install-time network error, or to transient conditions on the internet during the install process. It's also quite possible to manually uninstall the Visual J# Runtime after Dependency Tracker's installer has installed it.

To rectify this situation, you either reinstall Dependency Tracker or you can manually download and install the Visual J# Runtime for .NET 1.1. from Microsoft:

http://www.microsoft.com/downloads/deta ... laylang=en

All the best,

Dan

Comments

  • Options
    Bart ReadBart Read Posts: 997 Silver 1
    Hi everyone,


    Just thought I should add some additional points about the Visual J# redistributable that's needed to run SQL Dependency Tracker. As part of its installation process SQL Dependency Tracker should download and install this library for you, that is assuming it's not already on your system. However, sometimes this doesn't seem to work out quite the way it should, so if you are having problems you might find the following helpful.

    SQL Dependency Tracker will run with either .NET 1.1 or 2.0. If you have both of these framework versions installed SQL Dependency Tracker will run under 1.1.

    Now, you need to install the Visual J# redistributable that matches your .NET framework version. You can find all versions of this library at:

    http://msdn.microsoft.com/vjsharp/downl ... fault.aspx

    However, if you have both .NET 1.1 and 2.0 installed you should download and install the version for .NET 1.1 otherwise SQL Dependency Tracker will not work since it will run under the 1.1 framework in this instance. Otherwise, if you only have .NET 1.1 installed download the 1.1 J# redistributable, and for 2.0 download the 2.0 version.

    We have seen one instance in which a customer had the 1.0 version of the J# redistributable installed and SQL Dependency Tracker attempted to use this at runtime, which obviously didn't work out too well. We're not sure how or why this happened, but it's possible that the version of the 1.0 redistributable was incorrectly recognised as the required version during the installation process. If this also happens to you then you should ensure that you have either .NET 1.1 or 2.0 installed, and then follow the instructions in the previous paragraph and install the matching Visual J# Redistributable.

    Hopefully this should clear up a few problems that some of you have been having.


    Kind regards,
    Bart Read
    Principal Consultant
    bartread.com Ltd
  • Options
    Eddie DEddie D Posts: 1,792 Rose Gold 5
    The Microsoft Visual J# Version 2.0 Redistributable Package can be downloaded using the following link to the Microsoft Web Site: J# Runtime


    This redistributable package is required for SQL Dependency Tracker Version 2.4.

    A full list of the prerequisites and utilities for SQL Dependency Tracker can be found using this link: Prerequisites

    Many Thanks
    Eddie
    Eddie Davis
    Senior Product Support Engineer
    Redgate Software Ltd
    Email: support@red-gate.com
  • Options
    I've had a few problems getting this to work on a Windows 8.1 machine today - I tried a couple of the J# redist packages but many complained about incompatibilities (with itself bizarrely).

    I think you may need to switch on Framework 3.5 in the Windows Features in Control Panel -> Programs and Features ( I had it on already though).
    Eventually the one that worked was the package that is not described as ‘Second Edition‘ - it asked if I wanted to repair or uninstall and repair did the trick, but I suspect that was 'cos I had a few failed installs beforehand

    This is the link http://www.microsoft.com/downloads/deta ... laylang=en

    Hope it helps.
Sign In or Register to comment.