What are the challenges you face when working across database platforms? Take the survey
Options

Scheduled job is running too many times!

spireitespireite Posts: 25
edited May 25, 2006 11:49PM in SQL Backup Previous Versions
Hi,

I have a SQL2005 SP1 server, and SQLBackup 4.2. I have two jobs...

1. A Log backup scheduled every 30mins
2. A FULL db backup once a night (midnight)

I have a problem though. The Full backup is running approximately every 30minutes! This despite the schedule explicitly saying one a day (according to the interface). The log is running on its scheduled basis as I set.

Now it seems to me that SQLBackup may be confusing the two schedules? Whats happening? Has anyone seen this behaviour before?

Cheersz
Paul

Comments

  • Options
    peteypetey Posts: 2,358 New member
    Could you pls compare the full backup job schedule in the SQL Backup GUI and SQL Server Management Studio?
    Peter Yeoh
    SQL Backup Consultant Developer
    Associate, Yohz Software
    Beyond compression - SQL Backup goodies under the hood, updated for version 8
  • Options
    Both times match between the GUI and Management Studios schedule. In the end I rebooted the server and the schedule seems to be ok now since the reboot. Does this help?
  • Options
    peteypetey Posts: 2,358 New member
    Strange then, if the schedule information is correct. SQL Backup jobs have a 1 to 1 relation with their schedule, and the jobs themselves are ran by SQL Server Agent.
    Peter Yeoh
    SQL Backup Consultant Developer
    Associate, Yohz Software
    Beyond compression - SQL Backup goodies under the hood, updated for version 8
  • Options
    If SQLServers' SQL Agent handles it, what the SQL Backup Agent Service for?

    I now have another issue - in the full backup, there are 15 databases, its does all but one - which generates the following error - this is slap bang in the middle of the all the other database handles by that one job.


    25/05/2006 00:00:21: VDI error 1010: Failed to get configuration from server. Check that the SQL Server instance is running, and that you have the SQL Server Systems Administrator server role. Error code: (-2139684861: The api was waiting and the timeout interval had elapsed.)
    25/05/2006 00:00:21: SQL error 3013: BACKUP DATABASE is terminating abnormally.
    25/05/2006 00:00:21: SQL error 3007: The backup of the file or filegroup "sysft_ftcat_documentindex" is not permitted because it is not online. BACKUP can be performed by using the FILEGROUP or FILE clauses to restrict the selection to include only online data.
    25/05/2006 00:00:21:
    25/05/2006 00:00:22: Memory profile
    25/05/2006 00:00:22: Type Maximum Minimum Average Blk count Total
    25/05/2006 00:00:22:





    25/05/2006 00:00:22: Commit 24707072 4096 80590 9788 788815872
    25/05/2006 00:00:22: Reserve 330825728 4096 115204 8979 1034424320
    25/05/2006 00:00:22: Free 161202176 4096 2064827 157 324177920
    25/05/2006 00:00:22: Private 330825728 4096 95330 18331 1747501056
    25/05/2006 00:00:22: Mapped 1060864 4096 112900 55 6209536
    25/05/2006 00:00:22: Image 24707072 4096 182492 381 69529600
    25/05/2006 00:00:22:
  • Options
    peteypetey Posts: 2,358 New member
    The SQL Backup Agent service runs all the backup and restore requests passed from the extended stored procedure. So when a job runs, SQL Agents runs the extended stored procedure, which in turn is handed over to the SQL Backup Agent service.

    Re the other issue, that looks like a full text database which is offline. Depending on how you're running the backup, you'll either need to add or remove that database.

    If you're explicitly naming the databases e.g.

    BACKUP DATABASES [a, b, c] ...

    just remove that database from the list.

    If you're using the EXCLUDE statement e.g.

    BACKUP DATABASES EXCLUDE [model, tempdb] ....

    add that database to the list.
    Peter Yeoh
    SQL Backup Consultant Developer
    Associate, Yohz Software
    Beyond compression - SQL Backup goodies under the hood, updated for version 8
  • Options
    If I execute the Agent entry manually, then that database does backup through SQLBackup.
  • Options
    peteypetey Posts: 2,358 New member
    Pls disregard my previous post, I was under the mistaken impression that full text catalogs were stored in their own database, not as part of the user database. You should back up your database, and not exclude it.

    Googling on the issue turned up quite a few users with the same problem, but there does not seem to be a resolution that works all the time. It appears to have something to do with SQL 2000 databases created with full text catalogs, which were then migrated to SQL 2005.
    Peter Yeoh
    SQL Backup Consultant Developer
    Associate, Yohz Software
    Beyond compression - SQL Backup goodies under the hood, updated for version 8
Sign In or Register to comment.