problems with the asmx file and web reference

anandarajanandaraj Posts: 21
edited May 24, 2006 12:48PM in ANTS Load
I have downloaded the Ants - Gate application.

But even after downloading the tools,when i tried to access the page

http://localhost/antsloadtutorialwebser ... yees.asmx., it is giving a error that the page cannot be displayed.

Also when i tried to add this file as a web reference while creating a project, it said that there is a problem with the reference. Should we have to run any server prior to running this applicatoon?

Do elaborate me on this.

Comments

  • when i tried to add a web reference for testing a web service, it is giving the following message ..

    "there was a problem adding the web reference . unable to create proxy wrapper for this web service"

    wat could be the reason???
    do explain me in detial....i am not able to continue with my task...
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Sorry -- it sounds like either the application is not installed correctly or ASP .NET is not associated with .asmx files. Try running %systemroot%\microsoft.net\framework\v1.1.4322\aspnet_regiis -i.
  • i run the file which u mentioned...
    it prompted that asp.net was installed successfully...
    but still then i am facing the same problem...
    the file doesn't get loaded in the web browser...and when i try to add a web reference , it is giving a error notification....

    wat is the solution for this?? should i run any server????
  • when i type
    http://localhost/antsloadtutorialwebservice/employees.asmx in the browser, am getting the following error..

    The resource cannot be found.
    Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly.

    Requested Url: /antsloadtutorialwebservice/employees.asmx

    wat could be the reason for this?? do explain me ...
    also it is not allowing me to include the web reference for tesitng a web service...
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Now, the server is responding, but it's claiming that the page isn't there. I'd try reinstalling ANTS Load or running repair on ANTS Load from Add/Remove Programs.
  • thanks brian...now am able to access that particular page...
  • the example web service is working very fine...
    but i have a application for which i have to perform the testing of web services....the address comes like this http://
    when i type that url in the address field, it is reporting the same error that i received before.....not able to create proxy wrapper for this web service...

    so do explain me of how can i perform the testing of web services for that particular application??
  • Brian,

    I have an application for which i have to perform the testing of web services.
    I have a sequence of actions to be recorded in the application for which i have to perform the tessting of web services.

    I will give my requirements very specifically. I have to record a series of events like...login to the application, perform some operations and logoff. All thses actions has to be recorded and i should playback those also.
    Does the tool enable recording of web services by using a recorder?

    Also i want the scripts to be in the XML format. Whether the tool supports all these ??

    Regards,
    Anandaraj
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hello Anandaraj,

    The script recorder is for testing web sites rather than web services. Although this technically shouldn't stop you from using the recorder on webservices... the problem is that the webservice needs to expose an interface. Some of them do for testing reasons (you get the 'invoke' button when you go to that page in a browser), but in production this usually isn't true.

    My recommendation would be to figure out which webservice methods are invoked when you click the button, and use the webreferences script by uncommenting that method.

    If you still can't add the webreference, it may be because the webservice implements Webservice Extensions (WSE). These are nonstandard, Microsoft-specific enhancements to webservices. The reason that the webservice will not work is because they do not exist in the same SoapHttpClient namespace as a regular webservice. WSE as I understand it is a 'roll-your-own' webservice platform that doesn't conform to open webservice standards.
  • brian,

    i can't figure out the methods i am goin to use....because the user can perform any kind any sort of operations in the application after logging in which we can't exactly define by using a web method....

    the user has to login, perform some operations ( may be clicking some links in the page) and then logoff...all these events has to be recorded and the scripts should contain SOAP and XML requests instead of HTTP..whether it is possible in ANTS load?? do make it clear as these are my requirements......i haven't written any specific methods for the appln..since it doesn't go that way...
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hello,

    I don't think we can help you with this. The best thing to do would be to get with the developer who wrote the webservice. They probably have the best idea how to test it.
Sign In or Register to comment.