Error Comparing

Brian DonahueBrian Donahue Posts: 6,590 New member
Hi Shelby,

This sounds like the same linked server problem I brought up earlier in
the thread. You may be using the linked server without even knowing, because
when you use the option 'Advanced', the name of the linked server gets saved
in SQL Data Compare's Templates.xml file, which contains your data
comparision options. You might want to go into 'Advanced' and make sure that
box is blank even if you're using SQL Server authentication.

Sincerely,
Brian Donahue
Technical Support

"Shelby LeVino" <[email protected]> wrote in message
news:[email protected]
> Hi,
>
> I have two databases, one on the local server and another on a hosted box.
> When I SQLCompared the two databases everything went very nicely, but when
I
> tried to SQLDataCompare the two databses every table returned an 'error
> comparing' message. The first error had the following details: Error
> Comparing database.tablename [Microsoft][ODBCSql Server Driveer] [SQL
> Server] User does not have permission to perform this action.
>
> The second, and all subsequent comments are: Error Comparing
> database.tablename. Operation sis not allowed when the object is open.
>
> I have tried with integrated security as well as SQL server logins. I have
> also tried changing the order of the databases (compare local with remote,
> remote with local).
>
> I think the odd thing is that first, sql compare works, and second, sql
data
> compare has worked in the past.
>
> Help! What am I doing wrong?
>
>
This discussion has been closed.