Error when backing up

richardericharde Posts: 9
Hi there. I'm getting an error when trying to backup databases. Please note that I'm not using the GUI for Redgate. This is an automated system using Redgate's stored procedures. I have been using this routine for about 2 weeks now but about 2 days ago I started getting this message. Things I haven't tried are:
    Restarting the sql server service Bouncing the server Restarting the sql server agent service


Because this is a production server, to find a time to do this is difficult.

I am running SQL Server 2000 Standard with SP3a applied.

Here is an extract of the backup script I am running:
SET @vchrTSQL = 'master..sqlbackup N'''
+ '-SQL "BACKUP DATABASE TO DISK = ''''' + @vchrBackupLocation + ''''' WITH NAME = ''''' + @vchrBackupFileName + ''''''
+ ', DESCRIPTION = ''''' + 'Backuping up database: ' + @vchrDatabaseName + ' User: ' + CURRENT_USER + ' Date: ' + CONVERT(VARCHAR(20),GETDATE()) + ''''''
+ ', PASSWORD = ''''<ENCRYPTEDPASSWORD>iTeYc1w3cWw=</ENCRYPTEDPASSWORD>'''''
+ ', KEYSIZE = 128'
+ ', VERIFY'
+ ', ERASEFILES = ' + CONVERT(VARCHAR(3),@intRetainDays)
+ ', MAILTO_ONERROR = ''''' + @vchrSystemOperator + ''''''
+ ', COMPRESSION = 3"'''
EXEC(@vchrTSQL)


Here is the error message I am receiving:
SQL Backup (DLL v4.1.0.207)

SQB service did not acknowledge receipt of data: WAIT TIMEOUT
name value

exitcode 5240
sqlerrorcode 0

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hi,

    Sorry if this is bit of a basic question, but is your SQL Backup Agent Service running?
  • Yes I have confirmed that Server Agent Serivce is running. The backups were happening fine for nearly 2 weeks without a problem. I then recieve the error message described in the previous posting.

    As an aside, I also tried restoring a db to this sql server and it ran for about 24 hours before I cancelled it. I ran the script from QA and copied the script from the script tab in RedGate UI. However, when restoring the db to a different machine it worked fine. The sqb file is being restored over the network since all backups reside on a file server.

    I have now replaced the redgate backup routines to the original sql server backup routines and these backups are working fine.

    I have not yet restarted this sql server in question. I don't really want to have to restart this sql server every two weeks (if this is the solution) since this box does have a high availability within the organisation as well as being a pain in the neck.

    Regards
    Rich
  • I'm having the same issue as you, I was wondering were you able to find out what was causing the problem?
  • Hi aaoudi,

    I was forced to reboot the machine. I did this nearly 2 weeks ago. It seemes to have fixed the problem, however, it was about 2 weeks into the initial test before roll out to production that I started experiencing problems. It's getting close to the time lapse before this started happening so I'll post another to this thread to let you know how I get on.

    Saying all this though, I did notice that the Server Agent Service was taking nearly all of the processor time prior to rebooting the machine. There were some replication jobs running, but nothing that you would expect to do this. Because the Server Agent service was busy this would then affect the SQL Backup app since I got an error suggesting that the Agent Service was not responding due to it not being started.

    It's all still a mystery I'm afraid. I'm just hoping that the tests that I am running will not break again otherwise I'll have to consider not using RedGate backup s/w.

    Rich
  • I recommend you upgrade to version 4.2.

    Start menu -> All Programs -> SQL Backup -> Check for updates
    Helen Joyce
    SQL Backup Project Manager
    Red Gate Software
  • Thanks for the reply H. I'll do this.
    Rich
Sign In or Register to comment.